summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/libdbx/libdbx-1.0.3.ebuild')
-rw-r--r--net-mail/libdbx/libdbx-1.0.3.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/net-mail/libdbx/libdbx-1.0.3.ebuild b/net-mail/libdbx/libdbx-1.0.3.ebuild
index 4f8dd3227f74..199b0c314a25 100644
--- a/net-mail/libdbx/libdbx-1.0.3.ebuild
+++ b/net-mail/libdbx/libdbx-1.0.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_PN="libdbx"
MYFILE="${MY_PN}_${PV}.tgz"
@@ -11,16 +11,19 @@ MYFILE="${MY_PN}_${PV}.tgz"
DESCRIPTION="Tools and library for reading Outlook Express mailboxes (.dbx format)"
HOMEPAGE="https://sourceforge.net/projects/ol2mbox"
SRC_URI="mirror://sourceforge/ol2mbox/${MYFILE}"
+S="${WORKDIR}/${MY_PN}_${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 x86"
-IUSE=""
-S="${WORKDIR}/${MY_PN}_${PV}"
+PATCHES=(
+ "${FILESDIR}"/bad_c.patch
+)
src_prepare() {
- epatch "${FILESDIR}/bad_c.patch"
+ default
+
sed -i -e 's/-g/$(CFLAGS) $(LDFLAGS)/;s|gcc|$(CC)|g' Makefile || die
tc-export CC
}