summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mailshears/mailshears-0.0.2.ebuild')
-rw-r--r--net-mail/mailshears/mailshears-0.0.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-mail/mailshears/mailshears-0.0.2.ebuild b/net-mail/mailshears/mailshears-0.0.2.ebuild
new file mode 100644
index 000000000000..f3dc5b5c99e1
--- /dev/null
+++ b/net-mail/mailshears/mailshears-0.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+# The tests are dangerous and shouldn't be run by anyone!
+# They mess with your local postgres databases.
+RUBY_FAKEGEM_RECIPE_TEST=none
+RUBY_FAKEGEM_RECIPE_DOC=yard
+RUBY_FAKEGEM_EXTRADOC="doc/${PN}.example.conf.yml"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mangle your mail garden"
+HOMEPAGE="http://michael.orlitzky.com/code/mailshears.php"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/pg-0.1*"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman "doc/man1/${PN}.1"
+}