summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/notmuch/notmuch-0.29.1.ebuild')
-rw-r--r--net-mail/notmuch/notmuch-0.29.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-mail/notmuch/notmuch-0.29.1.ebuild b/net-mail/notmuch/notmuch-0.29.1.ebuild
index ffa74708369a..4984cf17d69a 100644
--- a/net-mail/notmuch/notmuch-0.29.1.ebuild
+++ b/net-mail/notmuch/notmuch-0.29.1.ebuild
@@ -131,7 +131,14 @@ src_prepare() {
append-cxxflags -g
fi
- [[ ${CHOST} == *-solaris* ]] && append-ldflags -lnsl -lsocket
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ append-ldflags -lnsl -lsocket # non-autoconf configure
+ # disable gpgme test using too old gpg-key
+ sed -i \
+ -e '/GNUPGHOME=/d' \
+ -e '/SESSION_KEY =/c|| false ;' \
+ configure || die
+ fi
}
src_configure() {