summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/onionrouter')
-rw-r--r--net-mail/onionrouter/Manifest1
-rw-r--r--net-mail/onionrouter/onionrouter-0.6.0.ebuild50
-rw-r--r--net-mail/onionrouter/onionrouter-9999.ebuild3
3 files changed, 51 insertions, 3 deletions
diff --git a/net-mail/onionrouter/Manifest b/net-mail/onionrouter/Manifest
index 3da566565405..a43c6b3bb626 100644
--- a/net-mail/onionrouter/Manifest
+++ b/net-mail/onionrouter/Manifest
@@ -1 +1,2 @@
DIST onionrouter-0.5.2.tar.gz 23497 BLAKE2B f025385323b182350e3481be62bbb9ed037d197d83ee19341f27ec04c391d6e1ee809b5db461437287485496ce139718f774d39de7ebd307ea92d5409220e135 SHA512 9c23a17401c0d56fc8d0b6bc3a0c899d604f6981457643b84040e9cf60626990bbd03fead66bba1c7d5723bd43d95c128bf457380e255f995951970b4788f126
+DIST onionrouter-0.6.0.tar.gz 26525 BLAKE2B 59d0709d3d0344422840b89908aedb97a0b869208d9f5e690bede317f0fe20a11ff1f2f2fac11a7827736ddc5e6d27ce6b12cd9395a82f31f7bb51ab4ca511c1 SHA512 251228e677ca1df182e943d692060d5ad83bcaf407c31e30eeb71e9f581d7140eb4edc8f00f7baa47e6561a5457c0f10b25e5c581902aaca7906780a2b8dc69c
diff --git a/net-mail/onionrouter/onionrouter-0.6.0.ebuild b/net-mail/onionrouter/onionrouter-0.6.0.ebuild
new file mode 100644
index 000000000000..2efd032bc84b
--- /dev/null
+++ b/net-mail/onionrouter/onionrouter-0.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 systemd
+
+DESCRIPTION=".onion discovery via SRV DNS lookups for use with postfix"
+HOMEPAGE="https://pypi.org/project/onionrouter/ https://github.com/ehloonion/onionrouter/"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ehloonion/onionrouter.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://pypi.io/packages/source/${PN::1}/${PN}/${P}.tar.gz"
+fi
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+')"
+BDEPEND="$(python_gen_cond_dep '
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+')"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ insinto /etc/onionrouter
+ doins "${S}/onionrouter/configs/onionrouter.ini"
+}
diff --git a/net-mail/onionrouter/onionrouter-9999.ebuild b/net-mail/onionrouter/onionrouter-9999.ebuild
index 35d74e96b3d0..2efd032bc84b 100644
--- a/net-mail/onionrouter/onionrouter-9999.ebuild
+++ b/net-mail/onionrouter/onionrouter-9999.ebuild
@@ -39,9 +39,6 @@ BDEPEND="$(python_gen_cond_dep '
distutils_enable_tests pytest
src_prepare() {
- # https://github.com/ehloonion/onionrouter/pull/15
- cp "${FILESDIR}/conftest.py" "${S}" || die
-
distutils-r1_src_prepare
}