summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/mu-1.8.11.ebuild88
2 files changed, 0 insertions, 89 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index a5132219d608..9892c742164b 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1,2 +1 @@
-DIST mu-1.8.11.tar.xz 543168 BLAKE2B 196007390b909057e27f9f864709c8dc9b20d6baa575938531a8d6aacb5d3244e55d50473771cb6e41a019b4d5013d9a51c6640d6274b53fad2e19dcafb5066d SHA512 24abc3499d3e6c9e55f7bf75d8c8fae68be5976b28edf3fa8c6e04e55acf8ad2356bdbc820fcd8cae327ed930f3f2164c4cd92108aafde6af1addac8f8411fe2
DIST mu-1.8.13.tar.xz 543696 BLAKE2B 7e96040b12630d8dd1320475e8b7e62b7f349767d331237838e2dd092df51c4f94cf8605d1266d26f4d2fa9aa092ba03546ed21968448302c3a12495702e46bb SHA512 c9dd7564070191e251e8e072042c0d2957e9c9c31064aececf24b9dc99a9b51c6bd60138e88bd86f175365775e98ba49e3bdb5bea02f7738b5e1e68efd7e1a7c
diff --git a/net-mail/mu/mu-1.8.11.ebuild b/net-mail/mu/mu-1.8.11.ebuild
deleted file mode 100644
index 62b981bf5db6..000000000000
--- a/net-mail/mu/mu-1.8.11.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp-common meson
-
-DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
-HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
-SRC_URI="https://github.com/djcb/mu/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~riscv x86 ~x64-macos"
-IUSE="emacs readline"
-
-DEPEND="
- dev-libs/glib:2
- dev-libs/gmime:3.0
- >=dev-libs/xapian-1.4:=
- emacs? ( >=app-editors/emacs-25.3:* )
- readline? ( sys-libs/readline:= )"
-RDEPEND="${DEPEND}"
-BDEPEND="
- sys-apps/texinfo
- virtual/pkgconfig
-"
-
-SITEFILE="70mu-gentoo-autoload.el"
-
-src_prepare() {
- default
-
- # Don't install NEWS.org into /usr/share/doc.
- sed -i '/NEWS.org/,+1 d' meson.build || die
- sed -i '/mu4e-about.org/d' mu4e/meson.build || die
-
- # Don't compress the info file.
- sed -i '/gzip/d' build-aux/meson-install-info.sh || die
-
- # Instead, put it in /usr/share/doc/${PF}.
- sed -i "/MU_DOC_DIR/s/mu/${PF}/" mu4e/meson.build || die
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_feature readline)
- -Demacs="$(usex emacs "${EMACS}" emacs-not-enabled)"
- # NOTE: Guile interface is deprecated to be removed shortly.
- -Dguile=disabled
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
-
- # Since meson no longer installs NEWS.org, install it with dodoc.
- # Also, it must be uncompressed so that it can be viewed with
- # mu4e-info.
- docompress -x /usr/share/doc/${PF}/NEWS.org
- dodoc NEWS.org
-
- # Same as above.
- docompress -x /usr/share/doc/${PF}/mu4e-about.org
- dodoc mu4e/mu4e-about.org
-}
-
-pkg_preinst() {
- if [[ -n ${REPLACING_VERSIONS} ]]; then
- elog "After upgrading from an old major version, you should"
- elog "rebuild your mail index."
- fi
-}
-
-pkg_postinst() {
- if use emacs; then
- einfo "To use mu4e you need to configure it in your .emacs file"
- einfo "See the manual for more information:"
- einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
-
- elisp-site-regen
- fi
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}