summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/balance/balance-3.57-r1.ebuild')
-rw-r--r--net-misc/balance/balance-3.57-r1.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/net-misc/balance/balance-3.57-r1.ebuild b/net-misc/balance/balance-3.57-r1.ebuild
index 1dbfe6c842cd..b432ff4b7e02 100644
--- a/net-misc/balance/balance-3.57-r1.ebuild
+++ b/net-misc/balance/balance-3.57-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit fcaps toolchain-funcs
+inherit fcaps flag-o-matic toolchain-funcs
DESCRIPTION="TCP Load Balancing Port Forwarder"
HOMEPAGE="https://balance.inlab.net"
@@ -25,6 +25,18 @@ src_prepare() {
tc-export CC
}
+src_compile() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/861599
+ # https://sourceforge.net/p/balance/bugs/13/
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
src_install() {
default