summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/bird/bird-1.6.0.ebuild')
-rw-r--r--net-misc/bird/bird-1.6.0.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/net-misc/bird/bird-1.6.0.ebuild b/net-misc/bird/bird-1.6.0.ebuild
deleted file mode 100644
index 580dd5694106..000000000000
--- a/net-misc/bird/bird-1.6.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A routing daemon implementing OSPF, RIPv2 & BGP for IPv4 or IPv6"
-HOMEPAGE="http://bird.network.cz"
-SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug ipv6"
-
-RDEPEND="sys-libs/ncurses
- sys-libs/readline"
-DEPEND="sys-devel/flex
- sys-devel/bison
- sys-devel/m4"
-
-src_prepare() {
- mkdir ipv6
- tar c --exclude ipv6 . | tar x -C ipv6
- eapply_user
-}
-
-src_configure() {
- econf \
- --enable-client \
- --disable-ipv6 \
- --localstatedir="${EPREFIX}/var" \
- $(use_enable debug)
-
- if use ipv6; then
- cd ipv6
- econf \
- --enable-client \
- --enable-ipv6 \
- --localstatedir="${EPREFIX}/var" \
- $(use_enable debug)
- fi
-}
-
-src_compile() {
- emake
- if use ipv6; then
- cd ipv6
- emake
- fi
-}
-
-src_install() {
- if use ipv6; then
- newbin ipv6/birdc birdc6
- newsbin ipv6/bird bird6
- newinitd "${FILESDIR}/initd-v6-${PN}-1.3.8" bird6
- fi
- dobin birdc
- dosbin bird
- newinitd "${FILESDIR}/initd-v4-${PN}-1.3.8" bird
- dodoc doc/bird.conf.example
-}