summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/Manifest3
-rw-r--r--net-misc/chrony/chrony-3.1.ebuild119
-rw-r--r--net-misc/chrony/chrony-3.3.ebuild121
-rw-r--r--net-misc/chrony/chrony-3.4.ebuild123
-rw-r--r--net-misc/chrony/files/chrony-3.4-systemd-gentoo.patch28
-rw-r--r--net-misc/chrony/files/chronyd.init-r169
-rw-r--r--net-misc/chrony/files/chronyd.service-r212
7 files changed, 0 insertions, 475 deletions
diff --git a/net-misc/chrony/Manifest b/net-misc/chrony/Manifest
index 868a62967f58..696b9d476e0c 100644
--- a/net-misc/chrony/Manifest
+++ b/net-misc/chrony/Manifest
@@ -1,4 +1 @@
-DIST chrony-3.1.tar.gz 424109 BLAKE2B eb6bc13905a05eab15b00919577cceb4c8c881b4881fbd0e19d966dca86ed6973c31618b1ae56b59cad989144bf59a0206328d50d9eb436fdb058684e74a1661 SHA512 4ba3a75c3634050bb63ba9ee80d9be7a295f44ce4d195a050e4be4738bd7dd807fe37f2289d7ead4a75272bd5ebadbd03c233c67f859e9b68871fca5a6671427
-DIST chrony-3.3.tar.gz 443571 BLAKE2B cc35f55b8d63eed85495f88b71c9285c68867a28b27c6c5e7d4475a77857ce4a09fbe561906757d66fee13b19d9ee750d41518050048776b2c0ef600407632e9 SHA512 36975d863599141e8e5b071d35cf67326b27f5b0da7ec942dbb4530377d10472b0729eea632e0702718b515cb2d5fd41a7eba158e6dade7f05adfb1bdffa5df0
-DIST chrony-3.4.tar.gz 453056 BLAKE2B 088eb18bfc9ae4a7a3d656dfabddc565bc4a0da995c172183bed12bc5df59e87ab7363ba64e3579cdb414da77bd7f1fe05b66e33474282df57daf1fd8a55e182 SHA512 4fbb0311c8d363a87edd6f5d1be3d8554da169f260ba23c1ad9e8c567808258c6fd7513ba630d6fa27453ecfd81f0ece0e26d5ee2f98ca47fbc9887181a36918
DIST chrony-3.5.tar.gz 458226 BLAKE2B 611f21e36c6e745208e00eba988519fcd912c6c0c3518c953591f43224dc3da79f627027a6cd4bf9c4227e9f8659a69adbdb634252ff3920d2ef677e32012456 SHA512 c4f6376a44d71b6ac2b6d86e3d6fb4348642faeef7f3f3a4d6431627b5645efcc868b005cc398c8292bc3b63a1161fbd1a042c6ac2a0595843f908fe32eed90c
diff --git a/net-misc/chrony/chrony-3.1.ebuild b/net-misc/chrony/chrony-3.1.ebuild
deleted file mode 100644
index edc3c363eb8b..000000000000
--- a/net-misc/chrony/chrony-3.1.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils systemd toolchain-funcs
-
-DESCRIPTION="NTP client and server programs"
-HOMEPAGE="http://chrony.tuxfamily.org/"
-SRC_URI="http://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="~alpha amd64 arm hppa ppc ppc64 sparc x86"
-IUSE="caps +cmdmon html ipv6 libedit +ntp +phc pps readline +refclock +rtc selinux +adns"
-REQUIRED_USE="
- ?? ( libedit readline )
-"
-
-CDEPEND="
- caps? ( sys-libs/libcap )
- libedit? ( dev-libs/libedit )
- readline? ( >=sys-libs/readline-4.1-r4:= )
-"
-DEPEND="
- ${CDEPEND}
- html? ( dev-ruby/asciidoctor )
- pps? ( net-misc/pps-tools )
-"
-RDEPEND="
- ${CDEPEND}
- selinux? ( sec-policy/selinux-chronyd )
-"
-
-RESTRICT=test
-
-S="${WORKDIR}/${P/_/-}"
-
-src_prepare() {
- sed -i \
- -e 's:/etc/chrony\.:/etc/chrony/chrony.:g' \
- -e 's:/var/run:/run:g' \
- conf.c doc/*.man.in examples/* || die
-
- default
-}
-
-src_configure() {
- tc-export CC
-
- local CHRONY_EDITLINE
- # ./configure legend:
- # --disable-readline : disable line editing entirely
- # --without-readline : do not use sys-libs/readline (enabled by default)
- # --without-editline : do not use dev-libs/libedit (enabled by default)
- if ! use readline && ! use libedit; then
- CHRONY_EDITLINE='--disable-readline'
- else
- CHRONY_EDITLINE+=" $(usex readline '' --without-readline)"
- CHRONY_EDITLINE+=" $(usex libedit '' --without-editline)"
- fi
-
- # not an autotools generated script
- local CHRONY_CONFIGURE="
- ./configure \
- $(usex caps '' --disable-linuxcaps) \
- $(usex cmdmon '' --disable-cmdmon) \
- $(usex ipv6 '' --disable-ipv6) \
- $(usex ntp '' --disable-ntp) \
- $(usex phc '' --disable-phc) \
- $(usex pps '' --disable-pps) \
- $(usex rtc '' --disable-rtc) \
- $(usex refclock '' --disable-refclock) \
- $(usex adns '' --disable-asyncdns) \
- ${CHRONY_EDITLINE} \
- ${EXTRA_ECONF} \
- --docdir=/usr/share/doc/${PF} \
- --chronysockdir=/run/chrony \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --sysconfdir=/etc/chrony \
- --disable-sechash \
- --without-nss \
- --without-tomcrypt
- "
-
- # print the ./configure call to aid in future debugging
- einfo ${CHRONY_CONFIGURE}
- bash ${CHRONY_CONFIGURE} || die
-}
-
-src_compile() {
- emake all docs $(usex html '' 'ADOC=true')
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/chronyd.init-r1 chronyd
- newconfd "${FILESDIR}"/chronyd.conf chronyd
-
- insinto /etc/${PN}
- newins examples/chrony.conf.example1 chrony.conf
-
- docinto examples
- dodoc examples/*.example*
-
- if use html; then
- docinto html
- dodoc doc/*.html
- fi
-
- keepdir /var/{lib,log}/chrony
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
-
- systemd_newunit "${FILESDIR}"/chronyd.service-r2 chronyd.service
- systemd_enable_ntpunit 50-chrony chronyd.service
-}
diff --git a/net-misc/chrony/chrony-3.3.ebuild b/net-misc/chrony/chrony-3.3.ebuild
deleted file mode 100644
index a34cf9102e49..000000000000
--- a/net-misc/chrony/chrony-3.3.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils systemd toolchain-funcs
-
-DESCRIPTION="NTP client and server programs"
-HOMEPAGE="https://chrony.tuxfamily.org/"
-SRC_URI="https://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="~alpha amd64 ~arm hppa ~ppc ~ppc64 ~sparc x86"
-IUSE="caps +cmdmon html ipv6 libedit +ntp +phc pps readline +refclock +rtc seccomp selinux +adns"
-REQUIRED_USE="
- ?? ( libedit readline )
-"
-
-CDEPEND="
- caps? ( sys-libs/libcap )
- libedit? ( dev-libs/libedit )
- readline? ( >=sys-libs/readline-4.1-r4:= )
- seccomp? ( sys-libs/libseccomp )
-"
-DEPEND="
- ${CDEPEND}
- html? ( dev-ruby/asciidoctor )
- pps? ( net-misc/pps-tools )
-"
-RDEPEND="
- ${CDEPEND}
- selinux? ( sec-policy/selinux-chronyd )
-"
-
-RESTRICT=test
-
-S="${WORKDIR}/${P/_/-}"
-
-src_prepare() {
- sed -i \
- -e 's:/etc/chrony\.:/etc/chrony/chrony.:g' \
- -e 's:/var/run:/run:g' \
- conf.c doc/*.man.in examples/* || die
-
- default
-}
-
-src_configure() {
- tc-export CC
-
- local CHRONY_EDITLINE
- # ./configure legend:
- # --disable-readline : disable line editing entirely
- # --without-readline : do not use sys-libs/readline (enabled by default)
- # --without-editline : do not use dev-libs/libedit (enabled by default)
- if ! use readline && ! use libedit; then
- CHRONY_EDITLINE='--disable-readline'
- else
- CHRONY_EDITLINE+=" $(usex readline '' --without-readline)"
- CHRONY_EDITLINE+=" $(usex libedit '' --without-editline)"
- fi
-
- # not an autotools generated script
- local CHRONY_CONFIGURE="
- ./configure \
- $(use_enable seccomp scfilter) \
- $(usex adns '' --disable-asyncdns) \
- $(usex caps '' --disable-linuxcaps) \
- $(usex cmdmon '' --disable-cmdmon) \
- $(usex ipv6 '' --disable-ipv6) \
- $(usex ntp '' --disable-ntp) \
- $(usex phc '' --disable-phc) \
- $(usex pps '' --disable-pps) \
- $(usex refclock '' --disable-refclock) \
- $(usex rtc '' --disable-rtc) \
- ${CHRONY_EDITLINE} \
- ${EXTRA_ECONF} \
- --docdir=/usr/share/doc/${PF} \
- --chronysockdir=/run/chrony \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --sysconfdir=/etc/chrony \
- --disable-sechash \
- --without-nss \
- --without-tomcrypt
- "
-
- # print the ./configure call to aid in future debugging
- einfo ${CHRONY_CONFIGURE}
- bash ${CHRONY_CONFIGURE} || die
-}
-
-src_compile() {
- emake all docs $(usex html '' 'ADOC=true')
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/chronyd.init-r1 chronyd
- newconfd "${FILESDIR}"/chronyd.conf chronyd
-
- insinto /etc/${PN}
- newins examples/chrony.conf.example1 chrony.conf
-
- docinto examples
- dodoc examples/*.example*
-
- if use html; then
- docinto html
- dodoc doc/*.html
- fi
-
- keepdir /var/{lib,log}/chrony
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
-
- systemd_newunit "${FILESDIR}"/chronyd.service-r2 chronyd.service
- systemd_enable_ntpunit 50-chrony chronyd.service
-}
diff --git a/net-misc/chrony/chrony-3.4.ebuild b/net-misc/chrony/chrony-3.4.ebuild
deleted file mode 100644
index 749bf8e23efe..000000000000
--- a/net-misc/chrony/chrony-3.4.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils systemd toolchain-funcs
-
-DESCRIPTION="NTP client and server programs"
-HOMEPAGE="https://chrony.tuxfamily.org/"
-SRC_URI="https://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="caps +cmdmon html ipv6 libedit +ntp +phc pps readline +refclock +rtc seccomp selinux +adns"
-REQUIRED_USE="
- ?? ( libedit readline )
-"
-
-CDEPEND="
- caps? ( sys-libs/libcap )
- libedit? ( dev-libs/libedit )
- readline? ( >=sys-libs/readline-4.1-r4:= )
- seccomp? ( sys-libs/libseccomp )
-"
-DEPEND="
- ${CDEPEND}
- html? ( dev-ruby/asciidoctor )
- pps? ( net-misc/pps-tools )
-"
-RDEPEND="
- ${CDEPEND}
- selinux? ( sec-policy/selinux-chronyd )
-"
-
-RESTRICT=test
-
-S="${WORKDIR}/${P/_/-}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.4-systemd-gentoo.patch
-)
-
-src_prepare() {
- default
- sed -i \
- -e 's:/etc/chrony\.conf:/etc/chrony/chrony.conf:g' \
- doc/* examples/* || die
-}
-
-src_configure() {
- tc-export CC
-
- local CHRONY_EDITLINE
- # ./configure legend:
- # --disable-readline : disable line editing entirely
- # --without-readline : do not use sys-libs/readline (enabled by default)
- # --without-editline : do not use dev-libs/libedit (enabled by default)
- if ! use readline && ! use libedit; then
- CHRONY_EDITLINE='--disable-readline'
- else
- CHRONY_EDITLINE+=" $(usex readline '' --without-readline)"
- CHRONY_EDITLINE+=" $(usex libedit '' --without-editline)"
- fi
-
- # not an autotools generated script
- local CHRONY_CONFIGURE="
- ./configure \
- $(use_enable seccomp scfilter) \
- $(usex adns '' --disable-asyncdns) \
- $(usex caps '' --disable-linuxcaps) \
- $(usex cmdmon '' --disable-cmdmon) \
- $(usex ipv6 '' --disable-ipv6) \
- $(usex ntp '' --disable-ntp) \
- $(usex phc '' --disable-phc) \
- $(usex pps '' --disable-pps) \
- $(usex refclock '' --disable-refclock) \
- $(usex rtc '' --disable-rtc) \
- ${CHRONY_EDITLINE} \
- ${EXTRA_ECONF} \
- --chronysockdir=/run/chrony \
- --disable-sechash \
- --docdir=/usr/share/doc/${PF} \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --sysconfdir=/etc/chrony \
- --with-pidfile="${EPREFIX}/run/chrony/chronyd.pid"
- --without-nss \
- --without-tomcrypt
- "
-
- # print the ./configure call to aid in future debugging
- einfo ${CHRONY_CONFIGURE}
- bash ${CHRONY_CONFIGURE} || die
-}
-
-src_compile() {
- emake all docs $(usex html '' 'ADOC=true')
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/chronyd.init-r2 chronyd
- newconfd "${FILESDIR}"/chronyd.conf chronyd
-
- insinto /etc/${PN}
- newins examples/chrony.conf.example1 chrony.conf
-
- docinto examples
- dodoc examples/*.example*
-
- if use html; then
- docinto html
- dodoc doc/*.html
- fi
-
- keepdir /var/{lib,log}/chrony
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
-
- systemd_dounit examples/chronyd.service
-}
diff --git a/net-misc/chrony/files/chrony-3.4-systemd-gentoo.patch b/net-misc/chrony/files/chrony-3.4-systemd-gentoo.patch
deleted file mode 100644
index 63d6b7ed3398..000000000000
--- a/net-misc/chrony/files/chrony-3.4-systemd-gentoo.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From ba3ddefc90f58d30a365104cf6e930333e3a2704 Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Tue, 4 Sep 2018 13:01:06 -0400
-Subject: [PATCH] Tweak chronyd.service for Gentoo
-
----
- examples/chronyd.service | 5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
-
-diff --git a/examples/chronyd.service b/examples/chronyd.service
-index 1777413..ceed830 100644
---- a/examples/chronyd.service
-+++ b/examples/chronyd.service
-@@ -7,9 +7,8 @@ ConditionCapability=CAP_SYS_TIME
-
- [Service]
- Type=forking
--PIDFile=/var/run/chrony/chronyd.pid
--EnvironmentFile=-/etc/sysconfig/chronyd
--ExecStart=/usr/sbin/chronyd $OPTIONS
-+PIDFile=/run/chrony/chronyd.pid
-+ExecStart=/usr/sbin/chronyd
- PrivateTmp=yes
- ProtectHome=yes
- ProtectSystem=full
---
-2.18.0
-
diff --git a/net-misc/chrony/files/chronyd.init-r1 b/net-misc/chrony/files/chronyd.init-r1
deleted file mode 100644
index a76e2533f57d..000000000000
--- a/net-misc/chrony/files/chronyd.init-r1
+++ /dev/null
@@ -1,69 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- use dns
-}
-
-checkconfig() {
- # Note that /etc/chrony/chrony.keys is *NOT* checked. This
- # is because the user may have specified another key
- # file, and we don't want to force the user to use that
- # exact name for the key file.
- if [ ! -f "${CFGFILE}" ] ; then
- eerror "Please create ${CFGFILE} and the"
- eerror "chrony key file (usually /etc/chrony/chrony.keys)"
- eerror "by using the"
- eerror ""
- eerror " chrony.conf.example"
- eerror " chrony.keys.example"
- eerror ""
- eerror "files (from the documentation directory)"
- eerror "as templates."
- return 1
- else
- # Actually, I tried it, and chrony seems to ignore the pidfile
- # option. I'm going to leave it here anyway, since you never
- # know if it might be handy
- PIDFILE=`awk '/^ *pidfile/{print $2}' "${CFGFILE}"`
- fi
- return 0
-}
-
-setxtrarg() {
- if [ -c /dev/rtc ]; then
- grep -q '^rtcfile' "${CFGFILE}" && ARGS="${ARGS} -s"
- fi
- grep -q '^dumponexit$' "${CFGFILE}" && ARGS="${ARGS} -r"
- return 0
-}
-
-start() {
- checkconfig || return $?
- setxtrarg
-
- [ -n "${PIDFILE}" ] || PIDFILE=/run/chronyd.pid
-
- ebegin "Starting chronyd"
- start-stop-daemon \
- --start \
- --quiet \
- --exec /usr/sbin/chronyd \
- --pidfile "${PIDFILE}" \
- -- -f "${CFGFILE}" ${ARGS}
- eend $? "Failed to start chronyd"
-}
-
-stop() {
- checkconfig || return $?
-
- [ -n "${PIDFILE}" ] || PIDFILE=/run/chronyd.pid
-
- ebegin "Stopping chronyd"
- start-stop-daemon \
- --stop \
- --quiet \
- --pidfile "${PIDFILE}"
- eend $? "Failed to stop chronyd"
-}
diff --git a/net-misc/chrony/files/chronyd.service-r2 b/net-misc/chrony/files/chronyd.service-r2
deleted file mode 100644
index 90255675c838..000000000000
--- a/net-misc/chrony/files/chronyd.service-r2
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Chrony Network Time Service
-After=ntpdate.service sntp.service network.target
-Conflicts=ntpd.service systemd-timesyncd.service
-
-[Service]
-Type=forking
-ExecStart=/usr/sbin/chronyd
-PIDFile=/run/chronyd.pid
-
-[Install]
-WantedBy=multi-user.target