summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/connman-ui/connman-ui-0_p20150622-r1.ebuild')
-rw-r--r--net-misc/connman-ui/connman-ui-0_p20150622-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/connman-ui/connman-ui-0_p20150622-r1.ebuild b/net-misc/connman-ui/connman-ui-0_p20150622-r1.ebuild
new file mode 100644
index 000000000000..ab2877fbec31
--- /dev/null
+++ b/net-misc/connman-ui/connman-ui-0_p20150622-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+COMMIT="fce0af94e121bde77c7fa2ebd6a319f0180c5516"
+
+DESCRIPTION="A full-featured GTK based trayicon UI for ConnMan"
+HOMEPAGE="https://github.com/tbursztyka/connman-ui"
+SRC_URI="https://github.com/tbursztyka/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${PN}-${COMMIT}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/glib:2
+ sys-apps/dbus
+ x11-libs/gtk+:3
+"
+RDEPEND="${DEPEND}
+ net-misc/connman
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}