summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/dropbox-cli/dropbox-cli-1-r1.ebuild')
-rw-r--r--net-misc/dropbox-cli/dropbox-cli-1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/dropbox-cli/dropbox-cli-1-r1.ebuild b/net-misc/dropbox-cli/dropbox-cli-1-r1.ebuild
new file mode 100644
index 000000000000..28283d740c02
--- /dev/null
+++ b/net-misc/dropbox-cli/dropbox-cli-1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Cli interface for dropbox daemon (python)"
+HOMEPAGE="http://www.dropbox.com/"
+SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${P}.py.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="net-misc/dropbox
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin ${P}.py ${PN}
+ python_replicate_script "${D}"/usr/bin/${PN}
+}