summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/econnman/econnman-1.1-r2.ebuild')
-rw-r--r--net-misc/econnman/econnman-1.1-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/econnman/econnman-1.1-r2.ebuild b/net-misc/econnman/econnman-1.1-r2.ebuild
new file mode 100644
index 000000000000..7ccef1ed1883
--- /dev/null
+++ b/net-misc/econnman/econnman-1.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit python-single-r1
+
+DESCRIPTION="ConnMan User Interface written with EFL & python"
+HOMEPAGE="https://phab.enlightenment.org/w/projects/econnman/ https://www.enlightenment.org/"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-libs/efl[X,connman]
+ $(python_gen_cond_dep '
+ dev-python/python-efl[${PYTHON_USEDEP}]
+ ')"
+
+src_prepare() {
+ default
+ python_fix_shebang econnman-bin.in
+ sed -e \
+ 's/Categories=Network;Settings;Enlightenment;/Categories=Network;Settings;Dialup;Monitor;/g' \
+ -i data/desktop/econnman{.desktop,-agent.desktop} || die
+}