summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/electrum')
-rw-r--r--net-misc/electrum/Manifest3
-rw-r--r--net-misc/electrum/electrum-4.4.6.ebuild113
-rw-r--r--net-misc/electrum/electrum-4.5.0.ebuild114
-rw-r--r--net-misc/electrum/electrum-4.5.1.ebuild114
4 files changed, 0 insertions, 344 deletions
diff --git a/net-misc/electrum/Manifest b/net-misc/electrum/Manifest
index 2366163f07e6..4c6607b4ca9e 100644
--- a/net-misc/electrum/Manifest
+++ b/net-misc/electrum/Manifest
@@ -1,4 +1 @@
-DIST electrum-4.4.6.gh.tar.gz 5637532 BLAKE2B c6b7667c7699f9eb11013c446e203ac4205df1d78e2fb8d44309bd6340c85bd9b4f6aef364f9bf9da4f262b58c74a7830c290c0659cd388b4a50863926dffa67 SHA512 e643a7119a8746d0f9ae02888bcdcf5ab4216ea19483113cf270b2cf23c8c615f0013a2aaf2c5f488655bf52cd190ab76761fa54f4b851039bc7add0c05ad320
-DIST electrum-4.5.0.gh.tar.gz 4829345 BLAKE2B cd3de793df68af81ce1d9d5dfce62b433d4f8d23ebaaef63926c1be665770b16095ce59f4e89ec27aee29f5d814d154163748330bbb5428f406ba64eaeebd54e SHA512 237f87b3b527099e2e9dadbe5ae422075a4aea64dd434c31859fc032239e810e1c6641f4966dcd9ddfe396a31a67dc2fb4d4c8d5b1912b321a3408ccb805bd37
-DIST electrum-4.5.1.gh.tar.gz 4830405 BLAKE2B 8cc925b282f0401654653c525289c92a6d771d171191e40ce932b391a0946f8e0dce514e0aa45d8b4179739f7dfe52215c995b21d140227c2d5b5d21f9afaed1 SHA512 bfe3d89e1f8a96004175137105e7503fab431bd798ca5457d70d8ca50a1250ede81a426bf15f02e7c384ffdaf303ce4187971a79ca76019715136d3a3914d136
DIST electrum-4.5.2.gh.tar.gz 4831743 BLAKE2B 862afbe9d0bfef8f6799441f62f2f36958048262a46254afb67ff6c8838e708fe1d7c53b780a6710941cb04000732c2889e77deb2363fef65c89a9ca840e5987 SHA512 c72b576a4c054fb713600751dfdfd520a4c7fe68676eb8877fc6a744f2a3716ae5d49de8229787d1da8d284ac9d89515404ab17daa9bc860d05d54b5184eaa6d
diff --git a/net-misc/electrum/electrum-4.4.6.ebuild b/net-misc/electrum/electrum-4.4.6.ebuild
deleted file mode 100644
index 78458a0ccfd1..000000000000
--- a/net-misc/electrum/electrum-4.4.6.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-PYTHON_REQ_USE="ncurses?"
-
-inherit distutils-r1 xdg-utils
-
-DESCRIPTION="User friendly Bitcoin client"
-HOMEPAGE="
- https://electrum.org/
- https://github.com/spesmilo/electrum/
-"
-SRC_URI="
- https://github.com/spesmilo/electrum/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="cli ncurses qrcode +qt5"
-REQUIRED_USE="|| ( cli ncurses qt5 )"
-
-RDEPEND="
- ${PYTHON_DEPS}
- <dev-libs/libsecp256k1-0.4
- >=dev-python/aiohttp-socks-0.3[${PYTHON_USEDEP}]
- =dev-python/aiorpcX-0.22*[${PYTHON_USEDEP}]
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- dev-python/bitstring[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/dnspython-2[${PYTHON_USEDEP}]
- dev-python/pbkdf2[${PYTHON_USEDEP}]
- dev-python/pyperclip[${PYTHON_USEDEP}]
- dev-python/PySocks[${PYTHON_USEDEP}]
- dev-python/qrcode[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/protobuf-python-3.20[${PYTHON_USEDEP}]
- qrcode? ( media-gfx/zbar[v4l] )
- qt5? (
- dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
- )
- ncurses? ( $(python_gen_impl_dep 'ncurses') )
-"
-BDEPEND="
- test? (
- dev-python/pyaes[${PYTHON_USEDEP}]
- dev-python/pycryptodome[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # use backwards-compatible cryptodome API
- sed -i -e 's:Cryptodome:Crypto:' electrum/crypto.py || die
-
- # make qdarkstyle dep optional
- sed -i -e '/qdarkstyle/d' contrib/requirements/requirements.txt || die
-
- # remove upper bounds from deps
- sed -i -e 's:,<[0-9.]*::' contrib/requirements/requirements.txt || die
-
- local bestgui
- if use qt5; then
- bestgui=qt
- elif use ncurses; then
- bestgui=text
- else
- bestgui=stdio
- fi
- sed -i 's/^\([[:space:]]*\)\(config_options\['\''cwd'\''\] = .*\)$/\1\2\n\1config_options.setdefault("gui", "'"${bestgui}"'")\n/' ${PN}/${PN} || die
-
- eapply_user
-
- xdg_environment_reset
- distutils-r1_src_prepare
-}
-
-src_install() {
- dodoc RELEASE-NOTES
- distutils-r1_src_install
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-
- local v
- for v in ${REPLACING_VERSIONS}; do
- ver_test "${v}" -ge 4.3.4 && return
- done
-
- ewarn "If you are new to BitCoin, please be aware that:"
- ewarn "1. Cryptocurrencies are volatile. BTC has been subject to rapid"
- ewarn " changes of value in the past."
- ewarn "2. Cryptocurrency ownership is determined solely by the access to"
- ewarn " the private key. If the key is lost or stolen, BTC are unrevocably"
- ewarn " lost."
- ewarn "3. Proof-of-work based cryptocurrencies have negative environmental"
- ewarn " impact. BTC mining is consuming huge amounts of electricity."
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
diff --git a/net-misc/electrum/electrum-4.5.0.ebuild b/net-misc/electrum/electrum-4.5.0.ebuild
deleted file mode 100644
index 467eb433585d..000000000000
--- a/net-misc/electrum/electrum-4.5.0.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-PYTHON_REQ_USE="ncurses?"
-
-inherit distutils-r1 xdg-utils
-
-DESCRIPTION="User friendly Bitcoin client"
-HOMEPAGE="
- https://electrum.org/
- https://github.com/spesmilo/electrum/
-"
-SRC_URI="
- https://github.com/spesmilo/electrum/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cli ncurses qrcode +qt5"
-REQUIRED_USE="|| ( cli ncurses qt5 )"
-
-RDEPEND="
- ${PYTHON_DEPS}
- <dev-libs/libsecp256k1-0.4
- >=dev-python/aiohttp-socks-0.3[${PYTHON_USEDEP}]
- =dev-python/aiorpcX-0.22*[${PYTHON_USEDEP}]
- >=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]
- dev-python/bitstring[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/dnspython-2[${PYTHON_USEDEP}]
- dev-python/jsonpatch[${PYTHON_USEDEP}]
- dev-python/pbkdf2[${PYTHON_USEDEP}]
- dev-python/pyperclip[${PYTHON_USEDEP}]
- dev-python/PySocks[${PYTHON_USEDEP}]
- dev-python/qrcode[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/protobuf-python-3.20[${PYTHON_USEDEP}]
- qrcode? ( media-gfx/zbar[v4l] )
- qt5? (
- dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
- )
- ncurses? ( $(python_gen_impl_dep 'ncurses') )
-"
-BDEPEND="
- test? (
- dev-python/pyaes[${PYTHON_USEDEP}]
- dev-python/pycryptodome[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # use backwards-compatible cryptodome API
- sed -i -e 's:Cryptodome:Crypto:' electrum/crypto.py || die
-
- # make qdarkstyle dep optional
- sed -i -e '/qdarkstyle/d' contrib/requirements/requirements.txt || die
-
- # remove upper bounds from deps
- sed -i -e 's:,<[0-9.]*::' contrib/requirements/requirements.txt || die
-
- local bestgui
- if use qt5; then
- bestgui=qt
- elif use ncurses; then
- bestgui=text
- else
- bestgui=stdio
- fi
- sed -i 's/^\([[:space:]]*\)\(config_options\['\''cwd'\''\] = .*\)$/\1\2\n\1config_options.setdefault("gui", "'"${bestgui}"'")\n/' ${PN}/${PN} || die
-
- eapply_user
-
- xdg_environment_reset
- distutils-r1_src_prepare
-}
-
-src_install() {
- dodoc RELEASE-NOTES
- distutils-r1_src_install
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-
- local v
- for v in ${REPLACING_VERSIONS}; do
- ver_test "${v}" -ge 4.3.4 && return
- done
-
- ewarn "If you are new to BitCoin, please be aware that:"
- ewarn "1. Cryptocurrencies are volatile. BTC has been subject to rapid"
- ewarn " changes of value in the past."
- ewarn "2. Cryptocurrency ownership is determined solely by the access to"
- ewarn " the private key. If the key is lost or stolen, BTC are unrevocably"
- ewarn " lost."
- ewarn "3. Proof-of-work based cryptocurrencies have negative environmental"
- ewarn " impact. BTC mining is consuming huge amounts of electricity."
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
diff --git a/net-misc/electrum/electrum-4.5.1.ebuild b/net-misc/electrum/electrum-4.5.1.ebuild
deleted file mode 100644
index 467eb433585d..000000000000
--- a/net-misc/electrum/electrum-4.5.1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-PYTHON_REQ_USE="ncurses?"
-
-inherit distutils-r1 xdg-utils
-
-DESCRIPTION="User friendly Bitcoin client"
-HOMEPAGE="
- https://electrum.org/
- https://github.com/spesmilo/electrum/
-"
-SRC_URI="
- https://github.com/spesmilo/electrum/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cli ncurses qrcode +qt5"
-REQUIRED_USE="|| ( cli ncurses qt5 )"
-
-RDEPEND="
- ${PYTHON_DEPS}
- <dev-libs/libsecp256k1-0.4
- >=dev-python/aiohttp-socks-0.3[${PYTHON_USEDEP}]
- =dev-python/aiorpcX-0.22*[${PYTHON_USEDEP}]
- >=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]
- dev-python/bitstring[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/dnspython-2[${PYTHON_USEDEP}]
- dev-python/jsonpatch[${PYTHON_USEDEP}]
- dev-python/pbkdf2[${PYTHON_USEDEP}]
- dev-python/pyperclip[${PYTHON_USEDEP}]
- dev-python/PySocks[${PYTHON_USEDEP}]
- dev-python/qrcode[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/protobuf-python-3.20[${PYTHON_USEDEP}]
- qrcode? ( media-gfx/zbar[v4l] )
- qt5? (
- dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
- )
- ncurses? ( $(python_gen_impl_dep 'ncurses') )
-"
-BDEPEND="
- test? (
- dev-python/pyaes[${PYTHON_USEDEP}]
- dev-python/pycryptodome[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # use backwards-compatible cryptodome API
- sed -i -e 's:Cryptodome:Crypto:' electrum/crypto.py || die
-
- # make qdarkstyle dep optional
- sed -i -e '/qdarkstyle/d' contrib/requirements/requirements.txt || die
-
- # remove upper bounds from deps
- sed -i -e 's:,<[0-9.]*::' contrib/requirements/requirements.txt || die
-
- local bestgui
- if use qt5; then
- bestgui=qt
- elif use ncurses; then
- bestgui=text
- else
- bestgui=stdio
- fi
- sed -i 's/^\([[:space:]]*\)\(config_options\['\''cwd'\''\] = .*\)$/\1\2\n\1config_options.setdefault("gui", "'"${bestgui}"'")\n/' ${PN}/${PN} || die
-
- eapply_user
-
- xdg_environment_reset
- distutils-r1_src_prepare
-}
-
-src_install() {
- dodoc RELEASE-NOTES
- distutils-r1_src_install
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-
- local v
- for v in ${REPLACING_VERSIONS}; do
- ver_test "${v}" -ge 4.3.4 && return
- done
-
- ewarn "If you are new to BitCoin, please be aware that:"
- ewarn "1. Cryptocurrencies are volatile. BTC has been subject to rapid"
- ewarn " changes of value in the past."
- ewarn "2. Cryptocurrency ownership is determined solely by the access to"
- ewarn " the private key. If the key is lost or stolen, BTC are unrevocably"
- ewarn " lost."
- ewarn "3. Proof-of-work based cryptocurrencies have negative environmental"
- ewarn " impact. BTC mining is consuming huge amounts of electricity."
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}