summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ena-driver/ena-driver-2.0.2.ebuild')
-rw-r--r--net-misc/ena-driver/ena-driver-2.0.2.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/net-misc/ena-driver/ena-driver-2.0.2.ebuild b/net-misc/ena-driver/ena-driver-2.0.2.ebuild
deleted file mode 100644
index 04db47eb4f2c..000000000000
--- a/net-misc/ena-driver/ena-driver-2.0.2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit linux-info linux-mod
-
-DESCRIPTION="Amazon EC2 Elastic Network Adapter (ENA) kernel driver"
-HOMEPAGE="https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/enhanced-networking-ena.html"
-SRC_URI="https://github.com/amzn/amzn-drivers/archive/ena_linux_${PV}.zip -> ${P}-linux.zip"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-S="${WORKDIR}/amzn-drivers-ena_linux_${PV}/kernel/linux/ena"
-
-MODULE_NAMES="ena(net:${S}:${S})"
-BUILD_TARGETS="all"
-
-pkg_setup() {
- linux-mod_pkg_setup
- BUILD_PARAMS="CONFIG_MODULE_SIG=n KERNEL_DIR=${KV_DIR}"
-}
-
-src_prepare() {
- eapply_user
-
- sed -i -e 's!/lib/modules/\$(BUILD_KERNEL)/build!$(KERNEL_DIR)!g' \
- "Makefile" || die "Unable to fix Makefile"
-}
-
-src_install() {
- linux-mod_src_install
- dodoc README RELEASENOTES.md
-}