summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ena-driver/ena-driver-2.9.1.ebuild')
-rw-r--r--net-misc/ena-driver/ena-driver-2.9.1.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/net-misc/ena-driver/ena-driver-2.9.1.ebuild b/net-misc/ena-driver/ena-driver-2.9.1.ebuild
deleted file mode 100644
index eb8ed9525827..000000000000
--- a/net-misc/ena-driver/ena-driver-2.9.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit linux-mod-r1
-
-DESCRIPTION="Amazon EC2 Elastic Network Adapter (ENA) kernel driver"
-HOMEPAGE="https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/enhanced-networking-ena.html"
-SRC_URI="https://github.com/amzn/amzn-drivers/archive/ena_linux_${PV}.tar.gz -> ${P}-linux.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-BDEPEND="app-arch/unzip"
-
-S="${WORKDIR}/amzn-drivers-ena_linux_${PV}/kernel/linux/ena"
-
-CONFIG_CHECK="PCI_MSI !CPU_BIG_ENDIAN DIMLIB"
-DOCS=(
- README.rst
- RELEASENOTES.md
- ENA_Linux_Best_Practices.rst
-)
-
-src_compile() {
- local modlist=( ena=net )
- local modargs=( CONFIG_MODULE_SIG=n BUILD_KERNEL="${KV_FULL}" )
- linux-mod-r1_src_compile
-}