summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild')
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild b/net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild
new file mode 100644
index 000000000000..bda21a85cbfe
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit linux-info systemd
+
+DESCRIPTION="Multicast Routing Daemon using only IGMP signalling (Internet Group Management Protocol)"
+HOMEPAGE="http://sourceforge.net/projects/igmpproxy"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 Stanford"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}/${PN}-init.d" ${PN}
+ newconfd "${FILESDIR}/${PN}-conf.d" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}