summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/igmpproxy/igmpproxy-0.2.ebuild')
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-misc/igmpproxy/igmpproxy-0.2.ebuild b/net-misc/igmpproxy/igmpproxy-0.2.ebuild
new file mode 100644
index 000000000000..92b9f1240bdc
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit linux-info systemd
+
+DESCRIPTION="Multicast Routing Daemon using only IGMP signalling"
+HOMEPAGE="https://github.com/pali/igmpproxy"
+SRC_URI="https://github.com/pali/igmpproxy/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 Stanford"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ newinitd "${FILESDIR}/${PN}-init.d" ${PN}
+ newconfd "${FILESDIR}/${PN}-conf.d" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}