summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/monmotha')
-rw-r--r--net-misc/monmotha/Manifest1
-rw-r--r--net-misc/monmotha/files/monmotha.rc641
-rw-r--r--net-misc/monmotha/metadata.xml8
-rw-r--r--net-misc/monmotha/monmotha-2.3.8.ebuild45
4 files changed, 95 insertions, 0 deletions
diff --git a/net-misc/monmotha/Manifest b/net-misc/monmotha/Manifest
new file mode 100644
index 000000000000..dd8eff369734
--- /dev/null
+++ b/net-misc/monmotha/Manifest
@@ -0,0 +1 @@
+DIST rc.firewall-2.3.8 56204 SHA256 4d273d377baebfa5404cbaf87a40227b0000133ecb56c0c7539f548f516929f0
diff --git a/net-misc/monmotha/files/monmotha.rc6 b/net-misc/monmotha/files/monmotha.rc6
new file mode 100644
index 000000000000..50f31b9811cd
--- /dev/null
+++ b/net-misc/monmotha/files/monmotha.rc6
@@ -0,0 +1,41 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting the MonMotha Firewall"
+ /etc/monmotha/monmotha > /var/log/monmotha.log
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping the MonMotha Firewall"
+
+ # RESET ALL IPTABLES STUFF
+
+ /sbin/iptables -P INPUT ACCEPT
+ /sbin/iptables -P FORWARD ACCEPT
+ /sbin/iptables -P OUTPUT ACCEPT
+
+ /sbin/iptables -t nat -P PREROUTING ACCEPT
+ /sbin/iptables -t nat -P POSTROUTING ACCEPT
+ /sbin/iptables -t nat -P OUTPUT ACCEPT
+
+ /sbin/iptables -t mangle -P PREROUTING ACCEPT
+ /sbin/iptables -t mangle -P OUTPUT ACCEPT
+
+ /sbin/iptables -F
+ /sbin/iptables -t nat -F
+ /sbin/iptables -t mangle -F
+
+ /sbin/iptables -X
+ /sbin/iptables -t nat -X
+ /sbin/iptables -t mangle -X
+
+ eend $?
+}
diff --git a/net-misc/monmotha/metadata.xml b/net-misc/monmotha/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/net-misc/monmotha/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/monmotha/monmotha-2.3.8.ebuild b/net-misc/monmotha/monmotha-2.3.8.ebuild
new file mode 100644
index 000000000000..9ee024bf147c
--- /dev/null
+++ b/net-misc/monmotha/monmotha-2.3.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="MonMotha IPTables-based firewall script"
+HOMEPAGE="http://monmotha.mplug.org/firewall/"
+LICENSE="GPL-2"
+
+KEYWORDS="x86 ~amd64"
+IUSE=""
+SLOT="0"
+RDEPEND=">=net-firewall/iptables-1.2.5"
+
+MY_PVP=(${PV//[-\._]/ })
+
+S=${WORKDIR}
+
+SRC_URI="http://monmotha.mplug.org/~monmotha/firewall/firewall/${MY_PVP[0]}.${MY_PVP[1]}/rc.firewall-${PV}"
+
+src_unpack() {
+ cp "${DISTDIR}"/${A} "${S}"/
+}
+
+src_install() {
+ newinitd "${FILESDIR}/monmotha.rc6" monmotha
+ exeinto /etc/monmotha
+ newexe "${S}/rc.firewall-${PV}" monmotha
+}
+
+pkg_postinst () {
+ einfo "Don't forget to add the 'monmotha' startup script to your default"
+ einfo "runlevel by typing the following command:"
+ einfo ""
+ einfo " rc-update add monmotha default"
+ einfo ""
+ einfo "You need to edit /etc/monmotha/monmotha before using"
+ einfo "it. Enter the right vars in the file, start the script"
+ einfo "by typing: '/etc/init.d/monmotha start' and it should work."
+ einfo ""
+ einfo "Don't forget to change the path to iptables!!!"
+ einfo ""
+ einfo "Note: If You are stopping the firewall, all iptables rulesets"
+ einfo "will be flushed!!!"
+ einfo ""
+}