summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/mstpd/mstpd-0.0.9.ebuild')
-rw-r--r--net-misc/mstpd/mstpd-0.0.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-misc/mstpd/mstpd-0.0.9.ebuild b/net-misc/mstpd/mstpd-0.0.9.ebuild
new file mode 100644
index 000000000000..adbcac48da08
--- /dev/null
+++ b/net-misc/mstpd/mstpd-0.0.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1 systemd
+
+DESCRIPTION="Multiple spanning tree protocol daemon"
+HOMEPAGE="https://github.com/mstpd/mstpd"
+SRC_URI="https://github.com/mstpd/mstpd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-bashcompletiondir="$(get_bashcompdir)" \
+ --with-systemdunitdir="$(systemd_get_systemunitdir)" \
+ --localstatedir="${EPREFIX}"/var
+}