summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ndisc6')
-rw-r--r--net-misc/ndisc6/ndisc6-1.0.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/ndisc6/ndisc6-1.0.2-r1.ebuild b/net-misc/ndisc6/ndisc6-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..fe41f0c5524f
--- /dev/null
+++ b/net-misc/ndisc6/ndisc6-1.0.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Recursive DNS Servers discovery Daemon (rdnssd) for IPv6"
+HOMEPAGE="http://www.remlab.net/ndisc6/"
+SRC_URI="http://www.remlab.net/files/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug"
+
+DEPEND="dev-lang/perl
+ sys-devel/gettext"
+RDEPEND=""
+
+src_configure() {
+ econf $(use_enable debug assert)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ newinitd "${FILESDIR}"/rdnssd.rc-1 rdnssd || die
+ newconfd "${FILESDIR}"/rdnssd.conf rdnssd || die
+ exeinto /etc/rdnssd
+ newexe "${FILESDIR}"/resolvconf-1 resolvconf || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+}