summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/oidc-agent/oidc-agent-4.5.1.ebuild')
-rw-r--r--net-misc/oidc-agent/oidc-agent-4.5.1.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/net-misc/oidc-agent/oidc-agent-4.5.1.ebuild b/net-misc/oidc-agent/oidc-agent-4.5.1.ebuild
index d036c301e3b3..34e8613dbf7d 100644
--- a/net-misc/oidc-agent/oidc-agent-4.5.1.ebuild
+++ b/net-misc/oidc-agent/oidc-agent-4.5.1.ebuild
@@ -38,17 +38,24 @@ src_prepare() {
sed -i -e 's|^\(\s\+\)@|\1|' Makefile || die "Failed to increase verbosity in Makefile"
}
+oidc_emake() {
+ local mymakeargs=(
+ USE_CJSON_SO=1
+ USE_LIST_SO=0
+ USE_MUSTACHE_SO=0
+ USE_ARGP_SO=$(usex elibc_musl 1 0)
+ )
+
+ emake "${mymakeargs[@]}" $@
+}
+
src_compile() {
- local -x USE_CJSON_SO=1
- local -x USE_LIST_SO=0
- local -x USE_MUSTACHE_SO=0
- use elibc_musl && local -x USE_ARGP_SO=1
- emake -j1 create_obj_dir_structure create_picobj_dir_structure # Bug #880157
- emake
+ oidc_emake -j1 create_obj_dir_structure create_picobj_dir_structure # Bug #880157
+ oidc_emake
}
src_install() {
- emake \
+ oidc_emake \
PREFIX="${ED}" \
BIN_AFTER_INST_PATH="/usr" \
INCLUDE_PATH="${ED}"/usr/include \