summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/packETH/packETH-1.8.1.ebuild')
-rw-r--r--net-misc/packETH/packETH-1.8.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/packETH/packETH-1.8.1.ebuild b/net-misc/packETH/packETH-1.8.1.ebuild
new file mode 100644
index 000000000000..e8027e732b99
--- /dev/null
+++ b/net-misc/packETH/packETH-1.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="Packet generator tool for ethernet"
+HOMEPAGE="http://packeth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/packeth/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+"
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.1-libs-and-flags.patch
+)
+
+DOCS=( AUTHORS CHANGELOG README )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}