summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/packETH/packETH-2.1.ebuild')
-rw-r--r--net-misc/packETH/packETH-2.1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-misc/packETH/packETH-2.1.ebuild b/net-misc/packETH/packETH-2.1.ebuild
index 1bfcc33114eb..75ec8e7348eb 100644
--- a/net-misc/packETH/packETH-2.1.ebuild
+++ b/net-misc/packETH/packETH-2.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools
+inherit autotools toolchain-funcs
DESCRIPTION="Packet generator tool for ethernet"
HOMEPAGE="http://packeth.sourceforge.net/"
@@ -44,7 +44,8 @@ src_configure() {
src_compile() {
use gtk && default
- use cli && emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" -C cli
+ use cli && emake \
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" -C cli
}
src_install() {