summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/pipes/pipes-1.16.1-r1.ebuild')
-rw-r--r--net-misc/pipes/pipes-1.16.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/pipes/pipes-1.16.1-r1.ebuild b/net-misc/pipes/pipes-1.16.1-r1.ebuild
new file mode 100644
index 000000000000..7d8cc7dd125f
--- /dev/null
+++ b/net-misc/pipes/pipes-1.16.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Very versatile TCP pipes"
+HOMEPAGE="http://bisqwit.iki.fi/source/pipes.html"
+SRC_URI="http://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86"
+PATCHES=(
+ "${FILESDIR}"/${P}-execlp.patch
+)
+
+src_compile() {
+ # Prevent the build system from looking for dependencies
+ touch .depend || die
+
+ emake CC=$(tc-getCC) OPTIM="${CFLAGS}" LDFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin plis
+ dosym plis /usr/bin/pcon
+ dodoc ChangeLog Examples README.html
+}