summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/python-x2go/python-x2go-0.5.0.5.ebuild')
-rw-r--r--net-misc/python-x2go/python-x2go-0.5.0.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-misc/python-x2go/python-x2go-0.5.0.5.ebuild b/net-misc/python-x2go/python-x2go-0.5.0.5.ebuild
new file mode 100644
index 000000000000..8f666b8ffe49
--- /dev/null
+++ b/net-misc/python-x2go/python-x2go-0.5.0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="X2Go client-side Python API"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# TODO: minimal USE flag in net-misc/nx, we only need nxproxy/nxcomp
+DEPEND="dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ net-misc/nx"
+RDEPEND="${DEPEND}"