summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rdate/rdate-1.4-r4.ebuild')
-rw-r--r--net-misc/rdate/rdate-1.4-r4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/rdate/rdate-1.4-r4.ebuild b/net-misc/rdate/rdate-1.4-r4.ebuild
new file mode 100644
index 000000000000..98836d018399
--- /dev/null
+++ b/net-misc/rdate/rdate-1.4-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit flag-o-matic
+
+DESCRIPTION="use TCP or UDP to retrieve the current time of another machine"
+HOMEPAGE="http://www.apps.ietf.org/rfc/rfc868.html"
+SRC_URI="ftp://people.redhat.com/sopwith/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="ipv6"
+
+DEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS=/d' \
+ -e '/^rdate: /,+1d' \
+ -e '/\tinstall/s:\([^ ]\+\)$:$(DESTDIR)&:' \
+ Makefile || die "Sed failed!"
+}
+
+src_compile() {
+ use ipv6 && append-cppflags "-DINET6"
+ tc-export CC
+ emake
+}
+
+src_install(){
+ emake DESTDIR="${D}" install
+ newinitd "${FILESDIR}"/rdate-initd-1.4-r3 rdate
+ newconfd "${FILESDIR}"/rdate-confd rdate
+}