summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sipp')
-rw-r--r--net-misc/sipp/Manifest1
-rw-r--r--net-misc/sipp/sipp-3.6.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-misc/sipp/Manifest b/net-misc/sipp/Manifest
index b6391ce79e62..e013d3d46161 100644
--- a/net-misc/sipp/Manifest
+++ b/net-misc/sipp/Manifest
@@ -1 +1,2 @@
DIST sipp-3.6.0.tar.gz 1055201 BLAKE2B 48b431bfc33d3a03e6e972ef3ce184989afb12c7e0f20c6c3cf9b72ebcd65cb12cf4cab2b90e010d16e17b9bb4832f42915b104ea9bd1253242d304ab4f3cb32 SHA512 eecbc18a18558a3fbc4f7c841d1fc8bd5be4b0c5d2bb363a12faf730f3c6a0773a24f07dbf062e68baf1a93b21686fa09258d0e08b45b4f941eb5d573bb25c12
+DIST sipp-3.6.1.tar.gz 744407 BLAKE2B a201ecce624c15c51a66c3cb5ac467522755085419c2980b1f76340e7ffca5996516f34d7e52776a8aa0a2170ca2b7301030ecb50272a1c0a8e86aaf18a6de16 SHA512 58504c56ca0c14363fafc5d0598fd93857ef33cc5856f579a225fd0e38238f7d2c409127a18a368e22355cc3912758d4dba07bac7eaa3e8a0d2943ea5fdec602
diff --git a/net-misc/sipp/sipp-3.6.1.ebuild b/net-misc/sipp/sipp-3.6.1.ebuild
new file mode 100644
index 000000000000..3145570a2b56
--- /dev/null
+++ b/net-misc/sipp/sipp-3.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A free Open Source test tool / traffic generator for the SIP protocol"
+HOMEPAGE="http://sipp.sourceforge.net/ https://github.com/SIPp/sipp/releases"
+SRC_URI="https://github.com/SIPp/sipp/releases/download/v${PV}/${PF}.tar.gz"
+
+LICENSE="GPL-2 ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gsl +pcap sctp +ssl"
+
+DEPEND="sys-libs/ncurses:=
+ gsl? ( sci-libs/gsl:= )
+ pcap? (
+ net-libs/libpcap
+ net-libs/libnet:1.1
+ )
+ ssl? ( dev-libs/openssl:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ # version.h is in ${S}, and needs to be in ${S}/include for cmake to work.
+ ln -s ../version.h "${S}/include/" || die "Error creating version.h symlink"
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSL=$(usex gsl 1 0)
+ -DUSE_PCAP=$(usex pcap 1 0)
+ -DUSE_SCTP=$(usex sctp 1 0)
+ -DUSE_SSL=$(usex ssl 1 0)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ default
+ insinto /usr/share/${PN}
+ use pcap && doins pcap/*.pcap
+ dodoc CHANGES.md README.md
+}