summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sipsak/sipsak-0.9.6_p1-r2.ebuild')
-rw-r--r--net-misc/sipsak/sipsak-0.9.6_p1-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/sipsak/sipsak-0.9.6_p1-r2.ebuild b/net-misc/sipsak/sipsak-0.9.6_p1-r2.ebuild
new file mode 100644
index 000000000000..9810ba98e8e9
--- /dev/null
+++ b/net-misc/sipsak/sipsak-0.9.6_p1-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="small command line tool for testing SIP applications and devices"
+HOMEPAGE="http://sourceforge.net/projects/sipsak.berlios/"
+SRC_URI="mirror://sourceforge/sipsak.berlios/${P/_p/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="gnutls"
+
+RDEPEND="gnutls? ( net-libs/gnutls )
+ net-dns/c-ares"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P/_p1}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-callback.patch"
+}
+
+src_configure() {
+ append-cflags -std=gnu89
+
+ econf \
+ $(use_enable gnutls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}