summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sipsak/sipsak-0.9.7.ebuild')
-rw-r--r--net-misc/sipsak/sipsak-0.9.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/sipsak/sipsak-0.9.7.ebuild b/net-misc/sipsak/sipsak-0.9.7.ebuild
new file mode 100644
index 000000000000..ddc1785dbe0a
--- /dev/null
+++ b/net-misc/sipsak/sipsak-0.9.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="small command line tool for testing SIP applications and devices"
+HOMEPAGE="https://github.com/nils-ohlmeier/sipsak"
+SRC_URI="https://github.com/nils-ohlmeier/sipsak/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-libs/gnutls
+ net-dns/c-ares"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cflags -std=gnu89 -fcommon
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}