summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sjphone')
-rw-r--r--net-misc/sjphone/Manifest1
-rw-r--r--net-misc/sjphone/metadata.xml5
-rw-r--r--net-misc/sjphone/sjphone-1.60.2235.ebuild38
3 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/sjphone/Manifest b/net-misc/sjphone/Manifest
new file mode 100644
index 000000000000..9a865c15094c
--- /dev/null
+++ b/net-misc/sjphone/Manifest
@@ -0,0 +1 @@
+DIST SJphoneLnx-1.60.2235.tar.gz 4390024 SHA256 1d308fdee9b56fef0152833f7b9cf2a54a3391e5d4d353a094a300b722d5dff0
diff --git a/net-misc/sjphone/metadata.xml b/net-misc/sjphone/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/net-misc/sjphone/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/net-misc/sjphone/sjphone-1.60.2235.ebuild b/net-misc/sjphone/sjphone-1.60.2235.ebuild
new file mode 100644
index 000000000000..e4f20473d9d6
--- /dev/null
+++ b/net-misc/sjphone/sjphone-1.60.2235.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P="SJphoneLnx-${PV}"
+DESCRIPTION=" VOIP softphone supports both SIP and H.323 standards "
+HOMEPAGE="http://www.sjlabs.com/sjp.html"
+SRC_URI="http://www.sjlabs.com/preview/linux/${MY_P}.tar.gz"
+
+LICENSE="SJ-Labs IJG libpng ZLIB RSA W3C BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp"
+S=${WORKDIR}/${MY_P}
+
+RESTRICT="strip"
+
+src_install() {
+ insinto /opt/sjphone
+ doins -r lib/*
+ fperms a+x /opt/sjphone/sjphone
+
+ sed -i -e 's:$(dirname "$0"):/opt/sjphone:' \
+ -e 's:$WD/lib:$WD:' sjphone
+ dobin sjphone
+ dodoc README
+ doicon lib/sjphone.png
+ make_desktop_entry sjphone
+}