summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/socket/socket-1.5.ebuild')
-rw-r--r--net-misc/socket/socket-1.5.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/net-misc/socket/socket-1.5.ebuild b/net-misc/socket/socket-1.5.ebuild
index a08430d13f1f..be38d567737b 100644
--- a/net-misc/socket/socket-1.5.ebuild
+++ b/net-misc/socket/socket-1.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit base toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A shell-level interface to TCP sockets"
HOMEPAGE="http://www.jnickelsen.de/socket/"
@@ -12,10 +12,11 @@ SRC_URI="http://www.jnickelsen.de/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
-
IUSE="examples"
-PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+)
src_compile() {
emake CC="$(tc-getCC)"
@@ -25,6 +26,7 @@ src_install() {
dobin socket
doman socket.1
dodoc BLURB CHANGES README
+
if use examples; then
docinto examples
dodoc scripts/*