summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/tn5250')
-rw-r--r--net-misc/tn5250/Manifest1
-rw-r--r--net-misc/tn5250/metadata.xml11
-rw-r--r--net-misc/tn5250/tn5250-0.17.4.ebuild52
3 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/tn5250/Manifest b/net-misc/tn5250/Manifest
new file mode 100644
index 000000000000..3529cfcaee32
--- /dev/null
+++ b/net-misc/tn5250/Manifest
@@ -0,0 +1 @@
+DIST tn5250-0.17.4.tar.gz 648452 SHA256 354237d400dc46af887cb3ffa4ed1f2c371f5b8bee8be046a683a4ac9db4f9c5
diff --git a/net-misc/tn5250/metadata.xml b/net-misc/tn5250/metadata.xml
new file mode 100644
index 000000000000..5d6ac4ce30c5
--- /dev/null
+++ b/net-misc/tn5250/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>neurogeek@gentoo.org</email>
+ <name>Jesus Rivero</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">tn5250</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/tn5250/tn5250-0.17.4.ebuild b/net-misc/tn5250/tn5250-0.17.4.ebuild
new file mode 100644
index 000000000000..adf8e9992589
--- /dev/null
+++ b/net-misc/tn5250/tn5250-0.17.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils python
+
+DESCRIPTION="Telnet client for the IBM AS/400 that emulates 5250 terminals and printers"
+HOMEPAGE="http://tn5250.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ppc ~sparc x86"
+IUSE="X ssl"
+
+RDEPEND="sys-libs/ncurses
+ ssl? ( dev-libs/openssl )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-libs/libXt )"
+
+src_unpack() {
+ unpack ${A}
+
+ # Next, the Makefile for the terminfo settings tries to remove
+ # some files it doesn't have access to. We can just remove those
+ # lines.
+ cd "${S}/linux"
+ sed -i \
+ -e "/rm -f \/usr\/.*\/terminfo.*5250/d" Makefile.in \
+ || die "sed Makefile.in failed"
+ cd "${S}"
+}
+
+src_compile() {
+ econf \
+ $(use_with X x) \
+ $(use_with ssl) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ # The TERMINFO variable needs to be defined for the install
+ # to work, because the install calls "tic." man tic for
+ # details.
+ dodir /usr/share/terminfo
+ make DESTDIR="${D}" \
+ TERMINFO="${D}/usr/share/terminfo" install \
+ || die "make install failed"
+
+ dodoc AUTHORS NEWS README README.ssl TODO ChangeLog
+}