summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/turbovnc/files/turbovnc-3.0.90-fix-musl-compilation.patch')
-rw-r--r--net-misc/turbovnc/files/turbovnc-3.0.90-fix-musl-compilation.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/net-misc/turbovnc/files/turbovnc-3.0.90-fix-musl-compilation.patch b/net-misc/turbovnc/files/turbovnc-3.0.90-fix-musl-compilation.patch
new file mode 100644
index 000000000000..2ad9db5117ae
--- /dev/null
+++ b/net-misc/turbovnc/files/turbovnc-3.0.90-fix-musl-compilation.patch
@@ -0,0 +1,20 @@
+See bug https://bugs.gentoo.org/836723
+
+The error is this:
+
+/var/tmp/portage/net-misc/turbovnc-2.2.7-r2/work/turbovnc-2.2.7/unix/Xvnc/programs/Xserver/os/access.c: In function 'GetLocalClientCreds':
+/var/tmp/portage/net-misc/turbovnc-2.2.7-r2/work/turbovnc-2.2.7/unix/Xvnc/programs/Xserver/os/access.c:1178:18: error: storage size of 'peercred' isn't known
+ 1178 | struct ucred peercred;
+ | ^~~~~~~~
+
+--- a/unix/Xvnc/programs/Xserver/os/CMakeLists.txt
++++ b/unix/Xvnc/programs/Xserver/os/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ include_directories(../render ../../../lib/libsha1)
+
+ add_definitions(-DUNIXCONN -DTCPCONN -DHASXDMAUTH ${ServerOSDefines} -DXDMCP
+- -DHAVE_SHA1_IN_LIBSHA1)
++ -DHAVE_SHA1_IN_LIBSHA1 -D_GNU_SOURCE)
+ if(NOT CMAKE_SYSTEM_NAME STREQUAL "Linux")
+ # This is already defined for Linux
+ add_definitions(-DHAVE_ABSTRACT_SOCKETS)