summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/udpxy/udpxy-1.0.23.7-r2.ebuild')
-rw-r--r--net-misc/udpxy/udpxy-1.0.23.7-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/udpxy/udpxy-1.0.23.7-r2.ebuild b/net-misc/udpxy/udpxy-1.0.23.7-r2.ebuild
new file mode 100644
index 000000000000..f188248ade07
--- /dev/null
+++ b/net-misc/udpxy/udpxy-1.0.23.7-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils systemd toolchain-funcs versionator
+
+MY_PV=$(replace_version_separator 3 -)
+DESCRIPTION="Small-footprint daemon to relay multicast UDP traffic to client's TCP (HTTP) connection"
+HOMEPAGE="http://sourceforge.net/projects/udpxy/"
+SRC_URI="http://www.udpxy.com/download/1_23/${PN}.${MY_PV}-prod.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ eapply_user
+ tc-export CC
+}
+
+src_install() {
+ dobin udpxy
+ dosym udpxy /usr/bin/udpxrec
+
+ doman doc/en/*.1
+ dodoc CHANGES README
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}