summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/udpxy')
-rw-r--r--net-misc/udpxy/Manifest1
-rw-r--r--net-misc/udpxy/files/udpxy-1.0.21.2-LDFLAGS.patch11
-rw-r--r--net-misc/udpxy/files/udpxy.confd24
-rw-r--r--net-misc/udpxy/files/udpxy.initd21
-rw-r--r--net-misc/udpxy/files/udpxy.service9
-rw-r--r--net-misc/udpxy/metadata.xml7
-rw-r--r--net-misc/udpxy/udpxy-1.0.23.7-r1.ebuild34
7 files changed, 107 insertions, 0 deletions
diff --git a/net-misc/udpxy/Manifest b/net-misc/udpxy/Manifest
new file mode 100644
index 000000000000..4b18d8e27953
--- /dev/null
+++ b/net-misc/udpxy/Manifest
@@ -0,0 +1 @@
+DIST udpxy.1.0.23-7-prod.tar.gz 77591 SHA256 da13dab43b9b0e10a4f3e606d8b33ad5d0096901d9b59d1196177751cab5e5e0 SHA512 5bd37822f1d861b3828339175b7daebbf3ccb3969e808a319d3d3f054afbf7769d5f2705d25780a76819b3b7963af3a81af7d71556ba61274141142167907a23 WHIRLPOOL 03638c0fd0402e568ecd7c88d1339d486bc274c6310887d47b8df31e21f2d634511ac8e6c05de2f279a50c423c1a1d09ce848d6ade92389d9dbc86766b72ea5e
diff --git a/net-misc/udpxy/files/udpxy-1.0.21.2-LDFLAGS.patch b/net-misc/udpxy/files/udpxy-1.0.21.2-LDFLAGS.patch
new file mode 100644
index 000000000000..45f7644f92b0
--- /dev/null
+++ b/net-misc/udpxy/files/udpxy-1.0.21.2-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2012-03-02 16:10:33.127036949 +0400
++++ Makefile 2012-03-02 16:10:35.873002619 +0400
+@@ -169,7 +169,7 @@
+
+ $(EXEC) : $(DEPFILE) $(OBJ)
+ @rm -f $(EXEC)
+- $(CC) $(CFLAGS) $(COPT) -o $(EXEC) $(OBJ)
++ $(CC) $(CFLAGS) $(COPT) -o $(EXEC) $(OBJ) $(LDFLAGS)
+ @ls -l $(EXEC)
+ ifneq (yes, $(NO_UDPXREC))
+ @rm -f $(UDPXREC)
diff --git a/net-misc/udpxy/files/udpxy.confd b/net-misc/udpxy/files/udpxy.confd
new file mode 100644
index 000000000000..e8e12ddf2f0d
--- /dev/null
+++ b/net-misc/udpxy/files/udpxy.confd
@@ -0,0 +1,24 @@
+
+#udpxy 1.0_Chipmunk (build 8) standard
+#usage: udpxy [-vTS] [-a listenaddr] -p port [-m mcast_ifc_addr] [-c clients] [-l logfile] [-B sizeK] [-n nice_incr]
+# -v : enable verbose output [default = disabled]
+# -S : enable client statistics [default = disabled]
+# -T : do NOT run as a daemon [default = daemon if root]
+# -a : (IPv4) address/interface to listen on [default = 0.0.0.0]
+# -p : port to listen on
+# -m : (IPv4) address/interface of (multicast) source [default = 0.0.0.0]
+# -c : max clients to serve [default = 3, max = 16]
+# -l : log output to file [default = stderr]
+# -B : cache size (65536, 32Kb, 1Mb) for inbound (multicast) data [default = 65536 bytes]
+# -R : maximum messages to cache in buffer (-1 = all) [default = -1]
+# -H : maximum time (sec) to hold data in buffer (-1 = unlimited) [default = 4]
+# -n : nice value increment [default = 0]
+# -M : periodically renew multicast subscription (skip if 0 sec) [default = 0 sec]
+#Examples:
+# udpxy -p 4022
+# listen for HTTP requests on port 4022, all network interfaces
+# udpxy -a lan0 -p 4022 -m lan1
+# listen for HTTP requests on interface lan0, port 4022;
+# subscribe to multicast groups on interface lan1
+
+UDPXYOPTS="-p 4022"
diff --git a/net-misc/udpxy/files/udpxy.initd b/net-misc/udpxy/files/udpxy.initd
new file mode 100644
index 000000000000..c5bc1be01bd7
--- /dev/null
+++ b/net-misc/udpxy/files/udpxy.initd
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting udpxy"
+ start-stop-daemon --start --exec /usr/bin/udpxy -- ${UDPXYOPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping udpxy"
+ start-stop-daemon --stop --exec /usr/bin/udpxy
+ eend $?
+}
+
diff --git a/net-misc/udpxy/files/udpxy.service b/net-misc/udpxy/files/udpxy.service
new file mode 100644
index 000000000000..35ee208ed5dc
--- /dev/null
+++ b/net-misc/udpxy/files/udpxy.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=UDP-to-HTTP multicast traffic relay daemon
+After=syslog.target network.target
+
+[Service]
+ExecStart=/usr/bin/udpxy -T -p 4022
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-misc/udpxy/metadata.xml b/net-misc/udpxy/metadata.xml
new file mode 100644
index 000000000000..ff62877c67ae
--- /dev/null
+++ b/net-misc/udpxy/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-misc/udpxy/udpxy-1.0.23.7-r1.ebuild b/net-misc/udpxy/udpxy-1.0.23.7-r1.ebuild
new file mode 100644
index 000000000000..d03143555e8c
--- /dev/null
+++ b/net-misc/udpxy/udpxy-1.0.23.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd toolchain-funcs versionator
+
+MY_PV=$(replace_version_separator 3 -)
+DESCRIPTION="Small-footprint daemon to relay multicast UDP traffic to client's TCP (HTTP) connection"
+HOMEPAGE="http://sourceforge.net/projects/udpxy/"
+SRC_URI="http://www.udpxy.com/download/1_23/${PN}.${MY_PV}-prod.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ epatch_user
+ tc-export CC
+}
+
+src_install() {
+ dobin udpxy
+ dosym udpxy /usr/bin/udpxrec
+
+ doman doc/en/*.1
+ dodoc CHANGES README
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}