summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/unison/unison-2.48.15_p4.ebuild')
-rw-r--r--net-misc/unison/unison-2.48.15_p4.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-misc/unison/unison-2.48.15_p4.ebuild b/net-misc/unison/unison-2.48.15_p4.ebuild
index 93297eaf8275..e32810067cdd 100644
--- a/net-misc/unison/unison-2.48.15_p4.ebuild
+++ b/net-misc/unison/unison-2.48.15_p4.ebuild
@@ -74,10 +74,12 @@ src_install() {
for binname in unison unison-fsmonitor; do
newbin ${binname} ${binname}-${SLOT}
done
+
if use gtk; then
newicon -s scalable ../icons/U.svg ${PN}-${SLOT}.svg
- make_desktop_entry ${PN}-${SLOT} ${PN}-${SLOT} ${PN}-${SLOT}
+ make_desktop_entry Unison "${PN} (${SLOT})" "${EPREFIX}/usr/share/${PN}/${PN}-${SLOT}.svg"
fi
+
# No manual.pdf or manual.html available for this version
# if use doc; then
# DOCS+=( "${DISTDIR}/${P}-manual.pdf" )
@@ -90,7 +92,8 @@ pkg_postinst() {
elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
elog "in your profile files to access exactly this version over ssh."
elog "Or you can use 'eselect unison' to set the version."
- eselect unison update
+ eselect unison update || die
+
if use gtk; then
xdg_icon_cache_update
fi