summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wget/files')
-rw-r--r--net-misc/wget/files/wget-1.13.4-openssl-pkg-config.patch31
-rw-r--r--net-misc/wget/files/wget-1.14-gnutls-ssl.patch68
-rw-r--r--net-misc/wget/files/wget-1.14-pkg-config.patch200
-rw-r--r--net-misc/wget/files/wget-1.14-texi2pod.patch32
-rw-r--r--net-misc/wget/files/wget-1.14-wgetrc.patch31
-rw-r--r--net-misc/wget/files/wget-1.15-pkg-config.patch190
-rw-r--r--net-misc/wget/files/wget-1.15-test_fix.patch26
-rw-r--r--net-misc/wget/files/wget-1.16-fix-proxy-test-race.patch96
-rw-r--r--net-misc/wget/files/wget-1.16-openssl-header.patch31
-rw-r--r--net-misc/wget/files/wget-1.16-openssl-no-ssl3.patch34
-rw-r--r--net-misc/wget/files/wget-1.16-pkg-config.patch200
-rw-r--r--net-misc/wget/files/wget-1.16-tests-skip.patch27
12 files changed, 966 insertions, 0 deletions
diff --git a/net-misc/wget/files/wget-1.13.4-openssl-pkg-config.patch b/net-misc/wget/files/wget-1.13.4-openssl-pkg-config.patch
new file mode 100644
index 000000000000..97037cee724a
--- /dev/null
+++ b/net-misc/wget/files/wget-1.13.4-openssl-pkg-config.patch
@@ -0,0 +1,31 @@
+detect openssl via pkg-config if it's available
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -234,7 +234,17 @@ dnl
+ dnl Checks for libraries.
+ dnl
+
++PKG_PROG_PKG_CONFIG
++
+ AS_IF([test x"$with_ssl" = xopenssl], [
++ PKG_CHECK_MODULES([OPENSSL], [openssl], [
++ AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
++ AC_LIBOBJ([openssl])
++ LIBS="$OPENSSL_LIBS $LIBS"
++ CFLAGS="$OPENSSL_CFLAGS -DHAVE_LIBSSL $CFLAGS"
++ LIBSSL=" " # ntlm check below wants this #395349
++ ], [
++
+ dnl some versions of openssl use zlib compression
+ AC_CHECK_LIB(z, compress)
+
+@@ -294,6 +303,8 @@ AS_IF([test x$ssl_found != xyes],
+
+ ])
+
++])
++
+ ], [
+ # --with-ssl is not gnutls: check if it's no
+ AS_IF([test x"$with_ssl" != xno], [
diff --git a/net-misc/wget/files/wget-1.14-gnutls-ssl.patch b/net-misc/wget/files/wget-1.14-gnutls-ssl.patch
new file mode 100644
index 000000000000..8d5fe81e1b55
--- /dev/null
+++ b/net-misc/wget/files/wget-1.14-gnutls-ssl.patch
@@ -0,0 +1,68 @@
+https://bugs.gentoo.org/479948
+
+From ae80fd2ec75fafdbec9895b9d973f2966209d588 Mon Sep 17 00:00:00 2001
+From: mancha <mancha1@hush.com>
+Date: Sun, 5 May 2013 07:16:58 +0200
+Subject: [PATCH] gnutls: do not abort on non-fatal alerts during handshake
+
+Signed-off-by: mancha <mancha1@hush.com>
+---
+ src/ChangeLog | 6 ++++++
+ src/gnutls.c | 25 ++++++++++++++++++++++---
+ 2 files changed, 28 insertions(+), 3 deletions(-)
+
+2013-05-05 mancha <mancha1@hush.com> (tiny change)
+
+ * gnutls.c (ssl_connect_wget): Don't abort on non-fatal alerts
+ received during handshake. For example, when connecting to servers
+ using TSL-SNI that send warning-level unrecognized_name alerts.
+
+diff --git a/src/gnutls.c b/src/gnutls.c
+index 769b005..54422fc 100644
+--- a/src/gnutls.c
++++ b/src/gnutls.c
+@@ -376,8 +376,9 @@ ssl_connect_wget (int fd, const char *hostname)
+ {
+ struct wgnutls_transport_context *ctx;
+ gnutls_session_t session;
+- int err;
++ int err,alert;
+ gnutls_init (&session, GNUTLS_CLIENT);
++ const char *str;
+
+ /* We set the server name but only if it's not an IP address. */
+ if (! is_valid_ip_address (hostname))
+@@ -440,10 +441,28 @@ ssl_connect_wget (int fd, const char *hostname)
+ return false;
+ }
+
+- err = gnutls_handshake (session);
++ /* We don't stop the handshake process for non-fatal errors */
++ do
++ {
++ err = gnutls_handshake (session);
++ if (err < 0)
++ {
++ logprintf (LOG_NOTQUIET, "GnuTLS: %s\n", gnutls_strerror (err));
++ if (err == GNUTLS_E_WARNING_ALERT_RECEIVED ||
++ err == GNUTLS_E_FATAL_ALERT_RECEIVED)
++ {
++ alert = gnutls_alert_get (session);
++ str = gnutls_alert_get_name (alert);
++ if (str == NULL)
++ str = "(unknown)";
++ logprintf (LOG_NOTQUIET, "GnuTLS: received alert [%d]: %s\n", alert, str);
++ }
++ }
++ }
++ while (err == GNUTLS_E_WARNING_ALERT_RECEIVED && gnutls_error_is_fatal (err) == 0);
++
+ if (err < 0)
+ {
+- logprintf (LOG_NOTQUIET, "GnuTLS: %s\n", gnutls_strerror (err));
+ gnutls_deinit (session);
+ return false;
+ }
+--
+1.8.4.3
+
diff --git a/net-misc/wget/files/wget-1.14-pkg-config.patch b/net-misc/wget/files/wget-1.14-pkg-config.patch
new file mode 100644
index 000000000000..ea6364bf3ae1
--- /dev/null
+++ b/net-misc/wget/files/wget-1.14-pkg-config.patch
@@ -0,0 +1,200 @@
+From b97942cd6b496501b396ea3bc2710010f4591542 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 21 May 2012 18:39:59 -0400
+Subject: [PATCH] detect openssl/pcre/libuuid/zlib via pkg-config if it's
+ available
+
+Newer versions of these packages ship with pkg-config files, so if we can
+detect it via those, do so. If that fails, fall back to the old methods.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ configure.ac | 110 ++++++++++++++++++++++++++++++++++++++---------------------
+ 1 file changed, 71 insertions(+), 39 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 873c3c9..779ff39 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -68,6 +68,9 @@ AC_ARG_WITH(ssl,
+ AC_ARG_WITH(zlib,
+ [[ --without-zlib disable zlib ]])
+
++AC_ARG_ENABLE(pcre, AC_HELP_STRING([--disable-pcre],
++ [Disable PCRE style regular expressions]))
++
+ AC_ARG_ENABLE(opie,
+ [ --disable-opie disable support for opie or s/key FTP login],
+ ENABLE_OPIE=$enableval, ENABLE_OPIE=yes)
+@@ -237,11 +240,25 @@ dnl
+ dnl Checks for libraries.
+ dnl
+
++PKG_PROG_PKG_CONFIG
++
+ AS_IF([test x"$with_zlib" != xno], [
+- AC_CHECK_LIB(z, compress)
++ PKG_CHECK_MODULES([ZLIB], zlib, [
++ LIBS="$ZLIB_LIBS $LIBS"
++ CFLAGS="$ZLIB_CFLAGS $CFLAGS"
++ ], [
++ AC_CHECK_LIB(z, compress)
++ ])
+ ])
+
+ AS_IF([test x"$with_ssl" = xopenssl], [
++ PKG_CHECK_MODULES([OPENSSL], [openssl], [
++ AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
++ AC_LIBOBJ([openssl])
++ LIBS="$OPENSSL_LIBS $LIBS"
++ CFLAGS="$OPENSSL_CFLAGS -DHAVE_LIBSSL $CFLAGS"
++ LIBSSL=" " # ntlm check below wants this
++ ], [
+ dnl some versions of openssl use zlib compression
+ AC_CHECK_LIB(z, compress)
+
+@@ -278,29 +295,29 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ ;;
+ esac
+
+-AS_IF([test x$ssl_found != xyes],
+-[
+- dnl Now actually check for -lssl if it wasn't already found
+- AC_LIB_HAVE_LINKFLAGS([ssl], [crypto z], [
+- #include <openssl/ssl.h>
+- #include <openssl/x509.h>
+- #include <openssl/err.h>
+- #include <openssl/rand.h>
+- #include <openssl/des.h>
+- #include <openssl/md4.h>
+- #include <openssl/md5.h>
+- ], [SSL_library_init ()])
+- if test x"$LIBSSL" != x
+- then
+- ssl_found=yes
+- AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
+- AC_LIBOBJ([openssl])
+- LIBS="$LIBSSL $LIBS"
+- elif test x"$with_ssl" != x
+- then
+- AC_MSG_ERROR([--with-ssl=openssl was given, but SSL is not available.])
+- fi
+-])
++ AS_IF([test x$ssl_found != xyes], [
++ dnl Now actually check for -lssl if it wasn't already found
++ AC_LIB_HAVE_LINKFLAGS([ssl], [crypto z], [
++#include <openssl/ssl.h>
++#include <openssl/x509.h>
++#include <openssl/err.h>
++#include <openssl/rand.h>
++#include <openssl/des.h>
++#include <openssl/md4.h>
++#include <openssl/md5.h>
++ ], [SSL_library_init ()])
++ if test x"$LIBSSL" != x
++ then
++ ssl_found=yes
++ AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
++ AC_LIBOBJ([openssl])
++ LIBS="$LIBSSL $LIBS"
++ elif test x"$with_ssl" != x
++ then
++ AC_MSG_ERROR([--with-ssl=openssl was given, but SSL is not available.])
++ fi
++ ])
++ ])
+
+ ], [
+ # --with-ssl is not gnutls: check if it's no
+@@ -322,13 +322,20 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ ], [
+ # --with-ssl is not gnutls: check if it's no
+ AS_IF([test x"$with_ssl" != xno], [
+- dnl Now actually check for -lssl
++ dnl Now actually check for gnutls
+
++ PKG_CHECK_MODULES([GNUTLS], [gnutls], [
++ AC_MSG_NOTICE([compiling in support for SSL via GnuTLS])
++ AC_LIBOBJ([gnutls])
++ LIBS="$GNUTLS_LIBS $LIBS"
++ CFLAGS="$GNUTLS_CFLAGS -DHAVE_LIBGNUTLS $CFLAGS"
++ ], [
++
++ dnl Now actually check for -lgnutls
+ AC_CHECK_LIB(z, compress)
+ AC_CHECK_LIB(gpg-error, gpg_err_init)
+ AC_CHECK_LIB(gcrypt, gcry_control)
+
+- dnl Now actually check for -lssl
+ AC_LIB_HAVE_LINKFLAGS([gnutls], [], [
+ #include <gnutls/gnutls.h>
+ ], [gnutls_global_init()])
+@@ -342,6 +349,8 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ AC_MSG_ERROR([--with-ssl was given, but GNUTLS is not available.])
+ fi
+
++ ])
++
+ AC_CHECK_FUNCS(gnutls_priority_set_direct)
+ ]) # endif: --with-ssl == no?
+ ]) # endif: --with-ssl == openssl?
+@@ -524,26 +541,41 @@ dnl
+ dnl Check for UUID
+ dnl
+
+-AC_CHECK_HEADER(uuid/uuid.h,
+- AC_CHECK_LIB(uuid, uuid_generate,
+- [LIBS="${LIBS} -luuid"
+- AC_DEFINE([HAVE_LIBUUID], 1,
+- [Define if libuuid is available.])
+- ])
+-)
++AC_ARG_WITH(libuuid, AC_HELP_STRING([--without-libuuid],
++ [Generate UUIDs for WARC files via libuuid]))
++AS_IF([test "X$with_libuuid" != "Xno"],[
++ PKG_CHECK_MODULES([UUID], uuid, [
++ LIBS="$UUID_LIBS $LIBS"
++ CFLAGS="$UUID_CFLAGS $CFLAGS"
++ ], [
++ AC_CHECK_HEADER(uuid/uuid.h,
++ AC_CHECK_LIB(uuid, uuid_generate,
++ [LIBS="${LIBS} -luuid"
++ AC_DEFINE([HAVE_LIBUUID], 1,
++ [Define if libuuid is available.])
++ ])
++ )
++ ])
++])
+
+ dnl
+ dnl Check for PCRE
+ dnl
+
+-AC_CHECK_HEADER(pcre.h,
+- AC_CHECK_LIB(pcre, pcre_compile,
+- [LIBS="${LIBS} -lpcre"
+- AC_DEFINE([HAVE_LIBPCRE], 1,
+- [Define if libpcre is available.])
+- ])
+-)
+-
++AS_IF([test "X$enable_pcre" != "Xno"],[
++ PKG_CHECK_MODULES([PCRE], libpcre, [
++ LIBS="$PCRE_LIBS $LIBS"
++ CFLAGS="$PCRE_CFLAGS $CFLAGS"
++ ], [
++ AC_CHECK_HEADER(pcre.h,
++ AC_CHECK_LIB(pcre, pcre_compile,
++ [LIBS="${LIBS} -lpcre"
++ AC_DEFINE([HAVE_LIBPCRE], 1,
++ [Define if libpcre is available.])
++ ])
++ )
++ ])
++])
+
+ dnl Needed by src/Makefile.am
+ AM_CONDITIONAL([IRI_IS_ENABLED], [test "X$iri" != "Xno"])
+--
+1.8.4.3
+
diff --git a/net-misc/wget/files/wget-1.14-texi2pod.patch b/net-misc/wget/files/wget-1.14-texi2pod.patch
new file mode 100644
index 000000000000..700242bf4414
--- /dev/null
+++ b/net-misc/wget/files/wget-1.14-texi2pod.patch
@@ -0,0 +1,32 @@
+Submitted By: Ken Moffat <ken at linuxfromscratch dot org>
+Date: 2013-06-18
+Initial Package Version: 1.14
+Upstream Status: Submitted
+Origin: Arch
+Description: Build with perl-5.18.
+
+http://lists.gnu.org/archive/html/bug-wget/2013-06/msg00046.html
+
+From 2ed1707b5d8be66feb80cccfe8e11e719b52b99a Mon Sep 17 00:00:00 2001
+From: Dave Reisner <dreisner@archlinux.org>
+Date: Mon, 17 Jun 2013 23:31:46 +0530
+Subject: [PATCH] Fix error in texi2pod intriduced with Perl 5.18
+
+---
+
+diff --git a/doc/texi2pod.pl b/doc/texi2pod.pl
+index 86c4b18..9db6de1 100755
+--- a/doc/texi2pod.pl
++++ b/doc/texi2pod.pl
+@@ -291,7 +291,7 @@ while(<$inf>) {
+ if (defined $1) {
+ my $thing = $1;
+ if ($ic =~ /\@asis/) {
+- $_ = "\n=item $thing\n";
++ $_ = "\n=item C<$thing>\n";
+ } else {
+ # Entity escapes prevent munging by the <> processing below.
+ $_ = "\n=item $ic\&LT;$thing\&GT;\n";
+--
+1.8.3.1
+
diff --git a/net-misc/wget/files/wget-1.14-wgetrc.patch b/net-misc/wget/files/wget-1.14-wgetrc.patch
new file mode 100644
index 000000000000..8252aca4273c
--- /dev/null
+++ b/net-misc/wget/files/wget-1.14-wgetrc.patch
@@ -0,0 +1,31 @@
+link to the man manual pages
+
+document user agent issue vs portage fetching
+https://bugs.gentoo.org/327229
+
+--- a/doc/sample.wgetrc
++++ b/doc/sample.wgetrc
+@@ -5,7 +5,10 @@
+ ## You can use this file to change the default behaviour of wget or to
+ ## avoid having to type many many command-line options. This file does
+ ## not contain a comprehensive list of commands -- look at the manual
+-## to find out what you can put into this file.
++## to find out what you can put into this file. You can find this here:
++## $ info wget.info 'Startup File'
++## Or online here:
++## https://www.gnu.org/software/wget/manual/wget.html#Startup-File
+ ##
+ ## Wget initialization file can reside in /usr/local/etc/wgetrc
+ ## (global, for all users) or $HOME/.wgetrc (for a single user).
+@@ -14,6 +15,11 @@
+ ## as well as change them, in most cases, as the values on the
+ ## commented-out lines are the default values (e.g. "off").
+
++## You should not modify user_agent in the global config file. Instead,
++## keep that in your ~/.wgetrc file. If you really want to modify it
++## globally, make sure you set a custom FETCHCOMMAND in your package
++## manager because you will randomly break fetching with some servers.
++
+
+ ##
+ ## Global settings (useful for setting up in /usr/local/etc/wgetrc).
diff --git a/net-misc/wget/files/wget-1.15-pkg-config.patch b/net-misc/wget/files/wget-1.15-pkg-config.patch
new file mode 100644
index 000000000000..825ce1dacad8
--- /dev/null
+++ b/net-misc/wget/files/wget-1.15-pkg-config.patch
@@ -0,0 +1,190 @@
+From 5730efa0804468d342cb82d1ac9d5fc794ff572d Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Fri, 16 May 2014 11:29:53 +0200
+Subject: [PATCH] detect openssl/pcre/libuuid/zlib via pkg-config if it's
+ available
+
+Newer versions of these packages ship with pkg-config files, so if we can
+detect it via those, do so. If that fails, fall back to the old methods.
+
+Forward-ported to 1.15 release from b97942cd6b496501b396ea3bc2710010f4591542
+(Mon, 21 May 2012 18:39:59 -0400)
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 107 ++++++++++++++++++++++++++++++++++++++++++-----------------
+ 1 file changed, 77 insertions(+), 30 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index c5437bf..e0e2b25 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -68,6 +68,9 @@ AC_ARG_WITH(ssl,
+ AC_ARG_WITH(zlib,
+ [[ --without-zlib disable zlib ]])
+
++AC_ARG_ENABLE(pcre, AC_HELP_STRING([--disable-pcre],
++ [Disable PCRE style regular expressions]))
++
+ AC_ARG_ENABLE(opie,
+ [ --disable-opie disable support for opie or s/key FTP login],
+ ENABLE_OPIE=$enableval, ENABLE_OPIE=yes)
+@@ -237,12 +240,28 @@ dnl
+ dnl Checks for libraries.
+ dnl
+
++PKG_PROG_PKG_CONFIG
++
+ AS_IF([test x"$with_zlib" != xno], [
+ with_zlib=yes
+- AC_CHECK_LIB(z, compress)
++ PKG_CHECK_MODULES([ZLIB], zlib, [
++ LIBS="$ZLIB_LIBS $LIBS"
++ CFLAGS="$ZLIB_CFLAGS $CFLAGS"
++ AC_DEFINE([HAVE_LIBZ], [1], [Define if using zlib.])
++ ], [
++ AC_CHECK_LIB(z, compress)
++ ])
+ ])
+
+ AS_IF([test x"$with_ssl" = xopenssl], [
++ PKG_CHECK_MODULES([OPENSSL], [openssl], [
++ AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
++ AC_LIBOBJ([openssl])
++ LIBS="$OPENSSL_LIBS $LIBS"
++ CFLAGS="$OPENSSL_CFLAGS -DHAVE_LIBSSL $CFLAGS"
++ LIBSSL=" " # ntlm check below wants this
++ AC_DEFINE([HAVE_LIBSSL], [1], [Define if using openssl.])
++ ], [
+ dnl As of this writing (OpenSSL 0.9.6), the libcrypto shared library
+ dnl doesn't record its dependency on libdl, so we need to make sure
+ dnl -ldl ends up in LIBS on systems that have it. Most OSes use
+@@ -276,9 +295,9 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ ;;
+ esac
+
+- AS_IF([test x$ssl_found != xyes], [
+- dnl Now actually check for -lssl if it wasn't already found
+- AC_LIB_HAVE_LINKFLAGS([ssl], [crypto], [
++ AS_IF([test x$ssl_found != xyes], [
++ dnl Now actually check for -lssl if it wasn't already found
++ AC_LIB_HAVE_LINKFLAGS([ssl], [crypto], [
+ #include <openssl/ssl.h>
+ #include <openssl/x509.h>
+ #include <openssl/err.h>
+@@ -286,17 +305,18 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ #include <openssl/des.h>
+ #include <openssl/md4.h>
+ #include <openssl/md5.h>
+- ], [SSL_library_init ()])
+- if test x"$LIBSSL" != x
+- then
+- ssl_found=yes
+- AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
+- AC_LIBOBJ([openssl])
+- LIBS="$LIBSSL $LIBS"
+- elif test x"$with_ssl" != x
+- then
+- AC_MSG_ERROR([--with-ssl=openssl was given, but SSL is not available.])
+- fi
++ ], [SSL_library_init ()])
++ if test x"$LIBSSL" != x
++ then
++ ssl_found=yes
++ AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
++ AC_LIBOBJ([openssl])
++ LIBS="$LIBSSL $LIBS"
++ elif test x"$with_ssl" != x
++ then
++ AC_MSG_ERROR([--with-ssl=openssl was given, but SSL is not available.])
++ fi
++ ])
+ ])
+
+ ], [
+@@ -305,6 +325,14 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ dnl default is -lgnutls
+ with_ssl=gnutls
+
++ PKG_CHECK_MODULES([GNUTLS], [gnutls], [
++ AC_MSG_NOTICE([compiling in support for SSL via GnuTLS])
++ AC_LIBOBJ([gnutls])
++ LIBS="$GNUTLS_LIBS $LIBS"
++ CFLAGS="$GNUTLS_CFLAGS -DHAVE_LIBGNUTLS $CFLAGS"
++ AC_DEFINE([HAVE_LIBGNUTLS], [1], [Define if using gnutls.])
++ ], [
++
+ dnl Now actually check for -lgnutls
+ AC_LIB_HAVE_LINKFLAGS([gnutls], [], [
+ #include <gnutls/gnutls.h>
+@@ -319,6 +347,8 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ AC_MSG_ERROR([--with-ssl=gnutls was given, but GNUTLS is not available.])
+ fi
+
++ ])
++
+ AC_CHECK_FUNCS(gnutls_priority_set_direct)
+ ]) # endif: --with-ssl != no?
+ ]) # endif: --with-ssl == openssl?
+@@ -535,26 +565,43 @@ dnl
+ dnl Check for UUID
+ dnl
+
+-AC_CHECK_HEADER(uuid/uuid.h,
+- AC_CHECK_LIB(uuid, uuid_generate,
+- [LIBS="${LIBS} -luuid"
+- AC_DEFINE([HAVE_LIBUUID], 1,
+- [Define if libuuid is available.])
+- ])
+-)
++AC_ARG_WITH(libuuid, AC_HELP_STRING([--without-libuuid],
++ [Generate UUIDs for WARC files via libuuid]))
++AS_IF([test "X$with_libuuid" != "Xno"],[
++ PKG_CHECK_MODULES([UUID], uuid, [
++ LIBS="$UUID_LIBS $LIBS"
++ CFLAGS="$UUID_CFLAGS $CFLAGS"
++ AC_DEFINE([HAVE_LIBUUID], [1], [Define if using libuuid.])
++ ], [
++ AC_CHECK_HEADER(uuid/uuid.h,
++ AC_CHECK_LIB(uuid, uuid_generate,
++ [LIBS="${LIBS} -luuid"
++ AC_DEFINE([HAVE_LIBUUID], 1,
++ [Define if libuuid is available.])
++ ])
++ )
++ ])
++])
+
+ dnl
+ dnl Check for PCRE
+ dnl
+
+-AC_CHECK_HEADER(pcre.h,
+- AC_CHECK_LIB(pcre, pcre_compile,
+- [LIBS="${LIBS} -lpcre"
+- AC_DEFINE([HAVE_LIBPCRE], 1,
+- [Define if libpcre is available.])
+- ])
+-)
+-
++AS_IF([test "X$enable_pcre" != "Xno"],[
++ PKG_CHECK_MODULES([PCRE], libpcre, [
++ LIBS="$PCRE_LIBS $LIBS"
++ CFLAGS="$PCRE_CFLAGS $CFLAGS"
++ AC_DEFINE([HAVE_LIBPCRE], [1], [Define if using libpcre.])
++ ], [
++ AC_CHECK_HEADER(pcre.h,
++ AC_CHECK_LIB(pcre, pcre_compile,
++ [LIBS="${LIBS} -lpcre"
++ AC_DEFINE([HAVE_LIBPCRE], 1,
++ [Define if libpcre is available.])
++ ])
++ )
++ ])
++])
+
+ dnl Needed by src/Makefile.am
+ AM_CONDITIONAL([IRI_IS_ENABLED], [test "X$iri" != "Xno"])
+--
+1.9.3
+
diff --git a/net-misc/wget/files/wget-1.15-test_fix.patch b/net-misc/wget/files/wget-1.15-test_fix.patch
new file mode 100644
index 000000000000..754e44f2d92e
--- /dev/null
+++ b/net-misc/wget/files/wget-1.15-test_fix.patch
@@ -0,0 +1,26 @@
+From 3a47a1a918e9076133c046f8792cf68973f7c585 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Wed, 22 Jan 2014 22:07:18 +0100
+Subject: [PATCH] Don't use --debug in Test--post-file.px
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ tests/Test--post-file.px | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/Test--post-file.px b/tests/Test--post-file.px
+index 1c017b7..1212af6 100755
+--- a/tests/Test--post-file.px
++++ b/tests/Test--post-file.px
+@@ -8,7 +8,7 @@ use HTTPTest;
+
+ ###############################################################################
+
+-my $cmdline = $WgetTest::WGETPATH . " -d --post-file=nofile http://localhost:{{port}}/";
++my $cmdline = $WgetTest::WGETPATH . " --post-file=nofile http://localhost:{{port}}/";
+
+ my $expected_error_code = 3;
+
+--
+1.8.5.3
+
diff --git a/net-misc/wget/files/wget-1.16-fix-proxy-test-race.patch b/net-misc/wget/files/wget-1.16-fix-proxy-test-race.patch
new file mode 100644
index 000000000000..8edafd2948b4
--- /dev/null
+++ b/net-misc/wget/files/wget-1.16-fix-proxy-test-race.patch
@@ -0,0 +1,96 @@
+From 3eff3ad69a46364475e1f4abdf9412cfa87e3d6c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tim=20R=C3=BChsen?= <tim.ruehsen@gmx.de>
+Date: Tue, 28 Oct 2014 11:40:34 +0100
+Subject: [PATCH] synchronize client and server in Test-proxied-https-auth.px
+
+---
+ tests/ChangeLog | 4 ++++
+ tests/Test-proxied-https-auth.px | 36 +++++++++++++++++++++++++-----------
+ 2 files changed, 29 insertions(+), 11 deletions(-)
+
+2014-10-28 Tim Ruehsen <tim.ruehsen@gmx.de>
+
+ * tests/Test-proxied-https-auth.px: synchronize client and server
+
+diff --git a/tests/Test-proxied-https-auth.px b/tests/Test-proxied-https-auth.px
+index cc987ff..272003f 100755
+--- a/tests/Test-proxied-https-auth.px
++++ b/tests/Test-proxied-https-auth.px
+@@ -49,12 +49,15 @@ sub get_request {
+ }
+
+ sub do_server {
++ my ($synch_callback) = @_;
+ my $alrm = alarm 10;
+-
+ my $s = $SOCKET;
+ my $conn;
+ my $rqst;
+ my $rspn;
++
++ $synch_callback->();
++
+ for my $expect_inner_auth (0, 1) {
+ $conn = $s->accept;
+ $rqst = $conn->get_request;
+@@ -90,7 +93,7 @@ sub do_server {
+ Connection => 'close'
+ ]);
+ $rspn->protocol('HTTP/1.0');
+- print $rspn->as_string;
++ print STDERR $rspn->as_string;
+ print $conn $rspn->as_string;
+ } else {
+ die "No proxied auth\n" unless $rqst->header('Authorization');
+@@ -100,9 +103,9 @@ sub do_server {
+ 'Connection' => 'close',
+ ], "foobarbaz\n");
+ $rspn->protocol('HTTP/1.0');
+- print "=====\n";
+- print $rspn->as_string;
+- print "\n=====\n";
++ print STDERR "=====\n";
++ print STDERR $rspn->as_string;
++ print STDERR "\n=====\n";
+ print $conn $rspn->as_string;
+ }
+ $conn->close;
+@@ -113,18 +116,29 @@ sub do_server {
+ }
+
+ sub fork_server {
+- my $pid = fork;
+- die "Couldn't fork" if ($pid < 0);
+- return $pid if $pid;
++ pipe(FROM_CHILD, TO_PARENT) or die "Cannot create pipe!";
++ select((select(TO_PARENT), $| = 1)[0]);
++
++ my $pid = fork();
++ if ($pid < 0) {
++ die "Cannot fork";
++ } elsif ($pid == 0) {
++ # child
++ close FROM_CHILD;
++ do_server(sub { print TO_PARENT "SYNC\n"; close TO_PARENT });
++ } else {
++ # parent
++ close TO_PARENT;
++ chomp(my $line = <FROM_CHILD>);
++ close FROM_CHILD;
++ }
+
+- &do_server;
+- exit;
++ return $pid;
+ }
+
+ system ('rm -f needs-auth.txt');
+ my $pid = &fork_server;
+
+-sleep 1;
+ my $cmdline = $WgetTest::WGETPATH . " --user=fiddle-dee-dee"
+ . " --password=Dodgson -e https_proxy=localhost:{{port}}"
+ . " --no-check-certificate"
+--
+2.1.2
+
diff --git a/net-misc/wget/files/wget-1.16-openssl-header.patch b/net-misc/wget/files/wget-1.16-openssl-header.patch
new file mode 100644
index 000000000000..8df01c132454
--- /dev/null
+++ b/net-misc/wget/files/wget-1.16-openssl-header.patch
@@ -0,0 +1,31 @@
+From 1b5928e14fe5f40b2c8396fc622317790c9a368f Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 27 Oct 2014 14:39:41 -0400
+Subject: [PATCH] openssl: fix implicit decl warning
+
+Include the right header to fix:
+
+openssl.c: In function 'ssl_init':
+openssl.c:195:3: warning: implicit declaration of function
+ 'ENGINE_load_builtin_engines' [-Wimplicit-function-declaration]
+ ENGINE_load_builtin_engines();
+ ^
+---
+ src/openssl.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/openssl.c b/src/openssl.c
+index e24954a..2a3e0d6 100644
+--- a/src/openssl.c
++++ b/src/openssl.c
+@@ -42,6 +42,7 @@ as that of the covered work. */
+ #include <openssl/rand.h>
+ #if OPENSSL_VERSION_NUMBER >= 0x00907000
+ #include <openssl/conf.h>
++#include <openssl/engine.h>
+ #endif
+
+ #include "utils.h"
+--
+2.1.2
+
diff --git a/net-misc/wget/files/wget-1.16-openssl-no-ssl3.patch b/net-misc/wget/files/wget-1.16-openssl-no-ssl3.patch
new file mode 100644
index 000000000000..641ea068c63f
--- /dev/null
+++ b/net-misc/wget/files/wget-1.16-openssl-no-ssl3.patch
@@ -0,0 +1,34 @@
+From c81e3df2bc4d06835791427d888d4ae04a2384bc Mon Sep 17 00:00:00 2001
+From: Peter Meiser <meiser@gmx-topmail.de>
+Date: Wed, 29 Oct 2014 19:26:28 +0100
+Subject: [PATCH] Add guard for OpenSSL without SSLv3
+
+---
+ src/ChangeLog | 5 +++++
+ src/openssl.c | 2 ++
+ 2 files changed, 7 insertions(+)
+
+2014-10-29 Peter Meiser <meiser@gmx-topmail.de> (tiny change)
+
+ * openssl.c (ssl_init) [! OPENSSL_NO_SSL3]: Add guard for OpenSSL
+ without SSLv3.
+
+diff --git a/src/openssl.c b/src/openssl.c
+index e24954a..6f11650 100644
+--- a/src/openssl.c
++++ b/src/openssl.c
+@@ -208,9 +208,11 @@ ssl_init (void)
+ meth = SSLv2_client_method ();
+ break;
+ #endif
++#ifndef OPENSSL_NO_SSL3
+ case secure_protocol_sslv3:
+ meth = SSLv3_client_method ();
+ break;
++#endif
+ case secure_protocol_auto:
+ case secure_protocol_pfs:
+ case secure_protocol_tlsv1:
+--
+2.1.2
+
diff --git a/net-misc/wget/files/wget-1.16-pkg-config.patch b/net-misc/wget/files/wget-1.16-pkg-config.patch
new file mode 100644
index 000000000000..0b8803bd2971
--- /dev/null
+++ b/net-misc/wget/files/wget-1.16-pkg-config.patch
@@ -0,0 +1,200 @@
+From 5730efa0804468d342cb82d1ac9d5fc794ff572d Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Fri, 16 May 2014 11:29:53 +0200
+Subject: [PATCH] detect openssl/pcre/libuuid/zlib via pkg-config if it's
+ available
+
+Newer versions of these packages ship with pkg-config files, so if we can
+detect it via those, do so. If that fails, fall back to the old methods.
+
+Forward-ported to 1.15 release from b97942cd6b496501b396ea3bc2710010f4591542
+(Mon, 21 May 2012 18:39:59 -0400)
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 107 ++++++++++++++++++++++++++++++++++++++++++-----------------
+ 1 file changed, 77 insertions(+), 30 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index c5437bf..e0e2b25 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -68,6 +68,9 @@ AC_ARG_WITH(ssl,
+ AC_ARG_WITH(zlib,
+ [[ --without-zlib disable zlib ]])
+
++AC_ARG_ENABLE(pcre, AC_HELP_STRING([--disable-pcre],
++ [Disable PCRE style regular expressions]))
++
+ AC_ARG_ENABLE(opie,
+ [ --disable-opie disable support for opie or s/key FTP login],
+ ENABLE_OPIE=$enableval, ENABLE_OPIE=yes)
+@@ -237,12 +240,28 @@ dnl
+ dnl Checks for libraries.
+ dnl
+
++PKG_PROG_PKG_CONFIG
++
+ AS_IF([test x"$with_zlib" != xno], [
+ with_zlib=yes
+- AC_CHECK_LIB(z, compress)
++ PKG_CHECK_MODULES([ZLIB], zlib, [
++ LIBS="$ZLIB_LIBS $LIBS"
++ CFLAGS="$ZLIB_CFLAGS $CFLAGS"
++ AC_DEFINE([HAVE_LIBZ], [1], [Define if using zlib.])
++ ], [
++ AC_CHECK_LIB(z, compress)
++ ])
+ ])
+
+ AS_IF([test x"$with_ssl" = xopenssl], [
++ PKG_CHECK_MODULES([OPENSSL], [openssl], [
++ AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
++ AC_LIBOBJ([openssl])
++ LIBS="$OPENSSL_LIBS $LIBS"
++ CFLAGS="$OPENSSL_CFLAGS -DHAVE_LIBSSL $CFLAGS"
++ LIBSSL=" " # ntlm check below wants this
++ AC_DEFINE([HAVE_LIBSSL], [1], [Define if using openssl.])
++ ], [
+ dnl As of this writing (OpenSSL 0.9.6), the libcrypto shared library
+ dnl doesn't record its dependency on libdl, so we need to make sure
+ dnl -ldl ends up in LIBS on systems that have it. Most OSes use
+@@ -276,9 +295,9 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ ;;
+ esac
+
+- AS_IF([test x$ssl_found != xyes], [
+- dnl Now actually check for -lssl if it wasn't already found
+- AC_LIB_HAVE_LINKFLAGS([ssl], [crypto], [
++ AS_IF([test x$ssl_found != xyes], [
++ dnl Now actually check for -lssl if it wasn't already found
++ AC_LIB_HAVE_LINKFLAGS([ssl], [crypto], [
+ #include <openssl/ssl.h>
+ #include <openssl/x509.h>
+ #include <openssl/err.h>
+@@ -286,17 +305,18 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ #include <openssl/des.h>
+ #include <openssl/md4.h>
+ #include <openssl/md5.h>
+- ], [SSL_library_init ()])
+- if test x"$LIBSSL" != x
+- then
+- ssl_found=yes
+- AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
+- AC_LIBOBJ([openssl])
+- LIBS="$LIBSSL $LIBS"
+- elif test x"$with_ssl" != x
+- then
+- AC_MSG_ERROR([--with-ssl=openssl was given, but SSL is not available.])
+- fi
++ ], [SSL_library_init ()])
++ if test x"$LIBSSL" != x
++ then
++ ssl_found=yes
++ AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
++ AC_LIBOBJ([openssl])
++ LIBS="$LIBSSL $LIBS"
++ elif test x"$with_ssl" != x
++ then
++ AC_MSG_ERROR([--with-ssl=openssl was given, but SSL is not available.])
++ fi
++ ])
+ ])
+
+ ], [
+@@ -305,6 +325,14 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ dnl default is -lgnutls
+ with_ssl=gnutls
+
++ PKG_CHECK_MODULES([GNUTLS], [gnutls], [
++ AC_MSG_NOTICE([compiling in support for SSL via GnuTLS])
++ AC_LIBOBJ([gnutls])
++ LIBS="$GNUTLS_LIBS $LIBS"
++ CFLAGS="$GNUTLS_CFLAGS -DHAVE_LIBGNUTLS $CFLAGS"
++ AC_DEFINE([HAVE_LIBGNUTLS], [1], [Define if using gnutls.])
++ ], [
++
+ dnl Now actually check for -lgnutls
+ AC_LIB_HAVE_LINKFLAGS([gnutls], [], [
+ #include <gnutls/gnutls.h>
+@@ -319,6 +347,8 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ AC_MSG_ERROR([--with-ssl=gnutls was given, but GNUTLS is not available.])
+ fi
+
++ ])
++
+ AC_CHECK_FUNCS(gnutls_priority_set_direct)
+ ]) # endif: --with-ssl != no?
+ ]) # endif: --with-ssl == openssl?
+@@ -542,32 +542,51 @@ fi
+ dnl
+ dnl Check for UUID
+ dnl
+-AC_CHECK_HEADER(uuid.h,
+- AC_CHECK_FUNC(uuid, uuid_create,
+- [AC_DEFINE([HAVE_UUID_CREATE], 1,
+- [Define if uuid_create is available.])
+- ])
+-)
+
+-AC_CHECK_HEADER(uuid/uuid.h,
+- AC_CHECK_LIB(uuid, uuid_generate,
+- [LIBS="${LIBS} -luuid"
+- AC_DEFINE([HAVE_LIBUUID], 1,
+- [Define if libuuid is available.])
+- ])
+-)
++AC_ARG_WITH(libuuid, AC_HELP_STRING([--without-libuuid],
++ [Generate UUIDs for WARC files via libuuid]))
++AS_IF([test "X$with_libuuid" != "Xno"],[
++ PKG_CHECK_MODULES([UUID], uuid, [
++ LIBS="$UUID_LIBS $LIBS"
++ CFLAGS="$UUID_CFLAGS $CFLAGS"
++ AC_DEFINE([HAVE_LIBUUID], [1], [Define if using libuuid.])
++ ], [
++ AC_CHECK_HEADER(uuid.h,
++ AC_CHECK_FUNC(uuid, uuid_create,
++ [AC_DEFINE([HAVE_UUID_CREATE], 1,
++ [Define if uuid_create is available.])
++ ])
++ )
++
++ AC_CHECK_HEADER(uuid/uuid.h,
++ AC_CHECK_LIB(uuid, uuid_generate,
++ [LIBS="${LIBS} -luuid"
++ AC_DEFINE([HAVE_LIBUUID], 1,
++ [Define if libuuid is available.])
++ ])
++ )
++ ])
++])
+
+ dnl
+ dnl Check for PCRE
+ dnl
+
+-AC_CHECK_HEADER(pcre.h,
+- AC_CHECK_LIB(pcre, pcre_compile,
+- [LIBS="${LIBS} -lpcre"
+- AC_DEFINE([HAVE_LIBPCRE], 1,
+- [Define if libpcre is available.])
+- ])
+-)
++AS_IF([test "X$enable_pcre" != "Xno"],[
++ PKG_CHECK_MODULES([PCRE], libpcre, [
++ LIBS="$PCRE_LIBS $LIBS"
++ CFLAGS="$PCRE_CFLAGS $CFLAGS"
++ AC_DEFINE([HAVE_LIBPCRE], [1], [Define if using libpcre.])
++ ], [
++ AC_CHECK_HEADER(pcre.h,
++ AC_CHECK_LIB(pcre, pcre_compile,
++ [LIBS="${LIBS} -lpcre"
++ AC_DEFINE([HAVE_LIBPCRE], 1,
++ [Define if libpcre is available.])
++ ])
++ )
++ ])
++])
+
+
+ dnl Needed by src/Makefile.am
diff --git a/net-misc/wget/files/wget-1.16-tests-skip.patch b/net-misc/wget/files/wget-1.16-tests-skip.patch
new file mode 100644
index 000000000000..ce07cc1d01da
--- /dev/null
+++ b/net-misc/wget/files/wget-1.16-tests-skip.patch
@@ -0,0 +1,27 @@
+From 9a85d61a39f9afd0f60e9e5fc59e7ade553c0541 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 27 Oct 2014 14:52:01 -0400
+Subject: [PATCH] tests: fix skip exit code
+
+The test harness looks for exit code 77 to mark tests as skipped, not
+exit 2. Switch over so we get SKIP instead of FAIL.
+---
+ tests/WgetFeature.pm | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/WgetFeature.pm b/tests/WgetFeature.pm
+index 0762314..118e79c 100644
+--- a/tests/WgetFeature.pm
++++ b/tests/WgetFeature.pm
+@@ -22,7 +22,7 @@ sub import
+
+ unless ($have_features{$feature}) {
+ print $skip_messages{$feature}, "\n";
+- exit 2; # skip
++ exit 77; # skip
+ }
+ }
+
+--
+2.1.2
+