summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wireguard/wireguard-9999.ebuild')
-rw-r--r--net-misc/wireguard/wireguard-9999.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/net-misc/wireguard/wireguard-9999.ebuild b/net-misc/wireguard/wireguard-9999.ebuild
index 4a27f4c10f87..637d226ded3b 100644
--- a/net-misc/wireguard/wireguard-9999.ebuild
+++ b/net-misc/wireguard/wireguard-9999.ebuild
@@ -14,8 +14,9 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://git.zx2c4.com/WireGuard"
KEYWORDS=""
else
- SRC_URI="https://git.zx2c4.com/WireGuard/snapshot/WireGuard-${PV}.tar.xz"
- KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://git.zx2c4.com/WireGuard/snapshot/experimental/${PV}.tar.xz -> ${P}.tar.xz"
+ S="${WORKDIR}/experimental/${PV}"
+ KEYWORDS="~amd64 ~x86 ~mips ~arm ~arm64"
fi
LICENSE="GPL-2"
@@ -53,3 +54,14 @@ src_install() {
linux-mod_src_install
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" -C src/tools install
}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ ewarn
+ ewarn "This software is experimental and has not yet been released."
+ ewarn "As such, it may contain significant issues. Please do not file"
+ ewarn "bug reports with Gentoo, but rather direct them upstream to:"
+ ewarn
+ ewarn " team@wireguard.io security@wireguard.io"
+ ewarn
+}