summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/x2goclient')
-rw-r--r--net-misc/x2goclient/Manifest5
-rw-r--r--net-misc/x2goclient/metadata.xml6
-rw-r--r--net-misc/x2goclient/x2goclient-4.0.2.0.ebuild79
-rw-r--r--net-misc/x2goclient/x2goclient-4.0.3.1.ebuild79
-rw-r--r--net-misc/x2goclient/x2goclient-4.0.3.2.ebuild79
-rw-r--r--net-misc/x2goclient/x2goclient-4.0.4.0.ebuild79
-rw-r--r--net-misc/x2goclient/x2goclient-4.0.5.0.ebuild79
7 files changed, 406 insertions, 0 deletions
diff --git a/net-misc/x2goclient/Manifest b/net-misc/x2goclient/Manifest
new file mode 100644
index 000000000000..24cb40ec275e
--- /dev/null
+++ b/net-misc/x2goclient/Manifest
@@ -0,0 +1,5 @@
+DIST x2goclient-4.0.2.0.tar.gz 1398919 SHA256 7b1d42e30041d469ef986e686a1dacb4d0fb55d04fdcfc20ad26f5a4282d30b3 SHA512 09dfec61961aa63bb7e67aca26b765cd663dfab74d800990bdd6384cbbe9152c9dec91e5b46f44c211b31a12323920c1f6478f05c32ac42e530ce15652fcdeb8 WHIRLPOOL 06a07b033567fa5e3174462179abb1ef392fd43dc2b6985c27e2c87e49b7dbb017cafdbbd91cd5eb8e1476cff4433a56892f244328bc78183f295566733ac9e4
+DIST x2goclient-4.0.3.1.tar.gz 1539521 SHA256 8a5a0d8112250ecc598a9811253081d16f87c17d0707e8f09671c7cb31942bad SHA512 3be070564d9f782e9f2bae162af476ffb3c738ff237f81aa3fdc7a87a3d2dcc03978513cfb538ce2d43f6ba5cd9b1f578a279222c1149e4cde576d3807f3c9eb WHIRLPOOL fd76a1238b567e5140796afb7254aff455378dd4cf81c8587d48ccdbd51aa97b48a5c39a7360fded7b532897e3ff1dd1357bda67442fa80a1408ad092c7a8279
+DIST x2goclient-4.0.3.2.tar.gz 1560536 SHA256 f65a70463eae3d6d9fe6e4379f4ffacda50080a11f196d2792742f5b67fa0c6f SHA512 e390948360cb93db553b157b8146c0222f10a070a7b3f699a0e3be94bba0498b6fc6c0e064b6ecf753afc25a7447e5162f44305688fc2e68423a5530d73f0431 WHIRLPOOL 3d0b6aec77a8096541e810bf0a70d73caf63f34121d6931f5d3c2a721c4cd8b70e0eef1c902decc6733feb9a1cb09d3146baf4429532a60a013d0c36727059f7
+DIST x2goclient-4.0.4.0.tar.gz 1571218 SHA256 86d05ce10039fe0a965cdc55086e00f4f3abc573a96f128b92f87081b7251657 SHA512 53c12e31e9cddc732f1d85f963103c99d3e051946f56b6eef861cb450a5ac69b7d09aceb2a1cb4ff8af949d56abe0c00dff649a1980e21ffbc6980a1a1f87e14 WHIRLPOOL 69bc539e2dd8b4953d3e15417f583d47a4aa6419e207fc6fda666de6b8cf695b85871c3e9995bcfd8cc930bc4b2334d08b1a905a77d5cc97377abde01cbed8bb
+DIST x2goclient-4.0.5.0.tar.gz 1577271 SHA256 242e91720c1e5830f64a632c111ac3c4b6f6690d5005454c8e025b00bfbe42a1 SHA512 4fd3ca6061a4a86d04a699e41b17a546b0ed31e784ff357749d56a8015b60e86d1205580e6e57347a64c6ce47eaa47f054a783c6c90fd6716912333c7858309a WHIRLPOOL 72125958ade3baebdc272621834980ca07290adb16ab3a2129325d7d7ad7692061d5a24c1d48bbcda1c6b925a84bcf97dc30386910d533c0c4ac2db11d0f239f
diff --git a/net-misc/x2goclient/metadata.xml b/net-misc/x2goclient/metadata.xml
new file mode 100644
index 000000000000..f009de1b9d2d
--- /dev/null
+++ b/net-misc/x2goclient/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>nx</herd>
+ <longdescription>The X2Go Qt client</longdescription>
+</pkgmetadata>
diff --git a/net-misc/x2goclient/x2goclient-4.0.2.0.ebuild b/net-misc/x2goclient/x2goclient-4.0.2.0.ebuild
new file mode 100644
index 000000000000..2b4c9fab07bf
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-4.0.2.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils nsplugins qt4-r2
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="ldap nsplugin"
+
+DEPEND=">=net-libs/libssh-0.6.0_rc1
+ net-print/cups
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ x11-libs/libXpm
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ net-misc/nx"
+
+CLIENT_BUILD=${WORKDIR}/${P}.client_build
+PLUGIN_BUILD=${WORKDIR}/${P}.plugin_build
+
+src_prepare() {
+ if ! use ldap; then
+ sed -e "s/-lldap//" -i x2goclient.pro || die
+ sed -e "s/#define USELDAP//" -i x2goclientconfig.h || die
+ fi
+
+ mkdir -p "${CLIENT_BUILD}"
+ use nsplugin && mkdir -p "${PLUGIN_BUILD}"
+}
+
+src_configure() {
+ cd "${CLIENT_BUILD}"
+ eqmake4 "${S}"/x2goclient.pro
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ X2GO_CLIENT_TARGET=plugin eqmake4 "${S}"/x2goclient.pro
+ fi
+}
+
+src_compile() {
+ cd "${CLIENT_BUILD}"
+ qt4-r2_src_compile
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ qt4-r2_src_compile
+ fi
+}
+
+src_install() {
+ dobin "${CLIENT_BUILD}"/${PN}
+
+ insinto /usr/share/pixmaps/x2goclient
+ doins -r icons/*
+
+ domenu desktop/${PN}.desktop
+ doman man/man?/*
+
+ if use nsplugin;
+ then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe "${PLUGIN_BUILD}"/libx2goplugin.so
+ fi
+
+ emake DESTDIR="${D}" PREFIX=/usr install_pluginprovider
+}
diff --git a/net-misc/x2goclient/x2goclient-4.0.3.1.ebuild b/net-misc/x2goclient/x2goclient-4.0.3.1.ebuild
new file mode 100644
index 000000000000..2b4c9fab07bf
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-4.0.3.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils nsplugins qt4-r2
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="ldap nsplugin"
+
+DEPEND=">=net-libs/libssh-0.6.0_rc1
+ net-print/cups
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ x11-libs/libXpm
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ net-misc/nx"
+
+CLIENT_BUILD=${WORKDIR}/${P}.client_build
+PLUGIN_BUILD=${WORKDIR}/${P}.plugin_build
+
+src_prepare() {
+ if ! use ldap; then
+ sed -e "s/-lldap//" -i x2goclient.pro || die
+ sed -e "s/#define USELDAP//" -i x2goclientconfig.h || die
+ fi
+
+ mkdir -p "${CLIENT_BUILD}"
+ use nsplugin && mkdir -p "${PLUGIN_BUILD}"
+}
+
+src_configure() {
+ cd "${CLIENT_BUILD}"
+ eqmake4 "${S}"/x2goclient.pro
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ X2GO_CLIENT_TARGET=plugin eqmake4 "${S}"/x2goclient.pro
+ fi
+}
+
+src_compile() {
+ cd "${CLIENT_BUILD}"
+ qt4-r2_src_compile
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ qt4-r2_src_compile
+ fi
+}
+
+src_install() {
+ dobin "${CLIENT_BUILD}"/${PN}
+
+ insinto /usr/share/pixmaps/x2goclient
+ doins -r icons/*
+
+ domenu desktop/${PN}.desktop
+ doman man/man?/*
+
+ if use nsplugin;
+ then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe "${PLUGIN_BUILD}"/libx2goplugin.so
+ fi
+
+ emake DESTDIR="${D}" PREFIX=/usr install_pluginprovider
+}
diff --git a/net-misc/x2goclient/x2goclient-4.0.3.2.ebuild b/net-misc/x2goclient/x2goclient-4.0.3.2.ebuild
new file mode 100644
index 000000000000..2b4c9fab07bf
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-4.0.3.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils nsplugins qt4-r2
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="ldap nsplugin"
+
+DEPEND=">=net-libs/libssh-0.6.0_rc1
+ net-print/cups
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ x11-libs/libXpm
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ net-misc/nx"
+
+CLIENT_BUILD=${WORKDIR}/${P}.client_build
+PLUGIN_BUILD=${WORKDIR}/${P}.plugin_build
+
+src_prepare() {
+ if ! use ldap; then
+ sed -e "s/-lldap//" -i x2goclient.pro || die
+ sed -e "s/#define USELDAP//" -i x2goclientconfig.h || die
+ fi
+
+ mkdir -p "${CLIENT_BUILD}"
+ use nsplugin && mkdir -p "${PLUGIN_BUILD}"
+}
+
+src_configure() {
+ cd "${CLIENT_BUILD}"
+ eqmake4 "${S}"/x2goclient.pro
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ X2GO_CLIENT_TARGET=plugin eqmake4 "${S}"/x2goclient.pro
+ fi
+}
+
+src_compile() {
+ cd "${CLIENT_BUILD}"
+ qt4-r2_src_compile
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ qt4-r2_src_compile
+ fi
+}
+
+src_install() {
+ dobin "${CLIENT_BUILD}"/${PN}
+
+ insinto /usr/share/pixmaps/x2goclient
+ doins -r icons/*
+
+ domenu desktop/${PN}.desktop
+ doman man/man?/*
+
+ if use nsplugin;
+ then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe "${PLUGIN_BUILD}"/libx2goplugin.so
+ fi
+
+ emake DESTDIR="${D}" PREFIX=/usr install_pluginprovider
+}
diff --git a/net-misc/x2goclient/x2goclient-4.0.4.0.ebuild b/net-misc/x2goclient/x2goclient-4.0.4.0.ebuild
new file mode 100644
index 000000000000..b4505fc64020
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-4.0.4.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils nsplugins qt4-r2
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap nsplugin"
+
+DEPEND=">=net-libs/libssh-0.6.0_rc1
+ net-print/cups
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ x11-libs/libXpm
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ net-misc/nx"
+
+CLIENT_BUILD=${WORKDIR}/${P}.client_build
+PLUGIN_BUILD=${WORKDIR}/${P}.plugin_build
+
+src_prepare() {
+ if ! use ldap; then
+ sed -e "s/-lldap//" -i x2goclient.pro || die
+ sed -e "s/#define USELDAP//" -i src/x2goclientconfig.h || die
+ fi
+
+ mkdir -p "${CLIENT_BUILD}"
+ use nsplugin && mkdir -p "${PLUGIN_BUILD}"
+}
+
+src_configure() {
+ cd "${CLIENT_BUILD}"
+ eqmake4 "${S}"/x2goclient.pro
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ X2GO_CLIENT_TARGET=plugin eqmake4 "${S}"/x2goclient.pro
+ fi
+}
+
+src_compile() {
+ cd "${CLIENT_BUILD}"
+ qt4-r2_src_compile
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ qt4-r2_src_compile
+ fi
+}
+
+src_install() {
+ dobin "${CLIENT_BUILD}"/${PN}
+
+ insinto /usr/share/pixmaps/x2goclient
+ doins res/img/icons/${PN}.xpm
+
+ domenu desktop/${PN}.desktop
+ doman man/man?/*
+
+ if use nsplugin;
+ then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe "${PLUGIN_BUILD}"/libx2goplugin.so
+ fi
+
+ emake DESTDIR="${D}" PREFIX=/usr install_pluginprovider
+}
diff --git a/net-misc/x2goclient/x2goclient-4.0.5.0.ebuild b/net-misc/x2goclient/x2goclient-4.0.5.0.ebuild
new file mode 100644
index 000000000000..b4505fc64020
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-4.0.5.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils nsplugins qt4-r2
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap nsplugin"
+
+DEPEND=">=net-libs/libssh-0.6.0_rc1
+ net-print/cups
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ x11-libs/libXpm
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ net-misc/nx"
+
+CLIENT_BUILD=${WORKDIR}/${P}.client_build
+PLUGIN_BUILD=${WORKDIR}/${P}.plugin_build
+
+src_prepare() {
+ if ! use ldap; then
+ sed -e "s/-lldap//" -i x2goclient.pro || die
+ sed -e "s/#define USELDAP//" -i src/x2goclientconfig.h || die
+ fi
+
+ mkdir -p "${CLIENT_BUILD}"
+ use nsplugin && mkdir -p "${PLUGIN_BUILD}"
+}
+
+src_configure() {
+ cd "${CLIENT_BUILD}"
+ eqmake4 "${S}"/x2goclient.pro
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ X2GO_CLIENT_TARGET=plugin eqmake4 "${S}"/x2goclient.pro
+ fi
+}
+
+src_compile() {
+ cd "${CLIENT_BUILD}"
+ qt4-r2_src_compile
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ qt4-r2_src_compile
+ fi
+}
+
+src_install() {
+ dobin "${CLIENT_BUILD}"/${PN}
+
+ insinto /usr/share/pixmaps/x2goclient
+ doins res/img/icons/${PN}.xpm
+
+ domenu desktop/${PN}.desktop
+ doman man/man?/*
+
+ if use nsplugin;
+ then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe "${PLUGIN_BUILD}"/libx2goplugin.so
+ fi
+
+ emake DESTDIR="${D}" PREFIX=/usr install_pluginprovider
+}