summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/asterisk-opus/Manifest2
-rw-r--r--net-misc/asterisk-opus/asterisk-opus-16.0.1.3.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/asterisk-opus/Manifest b/net-misc/asterisk-opus/Manifest
index 87a613cab205..cebc60a2b126 100644
--- a/net-misc/asterisk-opus/Manifest
+++ b/net-misc/asterisk-opus/Manifest
@@ -1,2 +1,4 @@
DIST codec_opus-13.0_1.3.0-x86_32.tar.gz 308059 BLAKE2B ec93fe29c030f2e63dffef882326c9f362e2a81c8de26eb04e96995c00acf965ea376555c0befa90bdf0f2592d40cc2e296abba720702a6cd7f6683f9784d533 SHA512 aa4aafa4c688a328eec81daafd0589fc3a25d22d374742a0500ca71763d4191a24b055e3eb6ecd9bd3a0556ef359ab9a8482b44e9c1633568136db4997284063
DIST codec_opus-13.0_1.3.0-x86_64.tar.gz 343694 BLAKE2B ff43085aabbfc4f4082dc22f11b12d62ddb631b46df492baef8786a1f76cbc6b2828091867d40c77f0c268ed2ba50148fd6a1394493b595342da408d6746fe20 SHA512 0932006e8537ddee8c73b598bf04b6b552e1bf9527c65abdd6f7b8ff7ef677e251bc4fff55233e5d7e715f9ff5b928347618ed0d14a1f6bc9c6c728303593213
+DIST codec_opus-16.0_1.3.0-x86_32.tar.gz 394187 BLAKE2B 0b187360ae65fe4cfd56f90c2f617da916ec4ee9046a6ab9af3764c9182fce22bdaccf79eb1917ff4535201a96adda84761b7bb829aa062751d6836c539caa58 SHA512 851c94f327ed8823069d1a83ca750a607780753d3ea37f52e8ca5ad4c14a419be1b86c47adb965722f27de0cca2a829a3454d3f2c44925c676d040e78d440ad1
+DIST codec_opus-16.0_1.3.0-x86_64.tar.gz 388551 BLAKE2B d36f4ce8e9414e0887232afe6fd15098e48eb5ccaf690f340d4a62eaac432342a61e43801260f0198bd68af58217ef2a9aacd6d46af99b192444fa59994ff590 SHA512 601d04de2bd4e67cd3d111c8a6c383ea3885180f8ab82c8943e0d09f8203cff3e6d45b6048843946d53b4002d01d31d92592107053e512b5347568050aba5ac7
diff --git a/net-misc/asterisk-opus/asterisk-opus-16.0.1.3.0.ebuild b/net-misc/asterisk-opus/asterisk-opus-16.0.1.3.0.ebuild
new file mode 100644
index 000000000000..43c46db99b3b
--- /dev/null
+++ b/net-misc/asterisk-opus/asterisk-opus-16.0.1.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="OPUS codec and supporting files for asterisk"
+HOMEPAGE="https://wiki.asterisk.org/wiki/display/AST/Codec+Opus"
+
+AST_PV="$(ver_cut 1-2)"
+MY_PV="$(ver_rs 2 _)"
+
+SRC_URI="amd64? (
+ https://downloads.digium.com/pub/telephony/codec_opus/asterisk-${AST_PV}/x86-64/codec_opus-${MY_PV}-x86_64.tar.gz
+)
+x86? (
+ https://downloads.digium.com/pub/telephony/codec_opus/asterisk-${AST_PV}/x86-32/codec_opus-${MY_PV}-x86_32.tar.gz
+)"
+
+LICENSE="Digium"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="=net-misc/asterisk-${PV%%.*}*"
+
+RESTRICT="mirror strip"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ QA_FLAGS_IGNORED="/usr/$(get_libdir)/asterisk/modules/codec_opus.so"
+}
+
+src_install() {
+ local arch
+
+ if use x86; then
+ arch=x86_32
+ elif use amd64; then
+ arch=x86_64
+ fi
+
+ dodoc codec_opus-${MY_PV}-${arch}/README
+ insinto /usr/$(get_libdir)/asterisk/modules/
+ doins "codec_opus-${MY_PV}-${arch}/codec_opus.so"
+
+ insinto /var/lib/asterisk/documentation/thirdparty
+ doins "codec_opus-${MY_PV}-${arch}/codec_opus_config-en_US.xml"
+}