summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/mptcpd/Manifest1
-rw-r--r--net-misc/mptcpd/mptcpd-0.11.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-misc/mptcpd/Manifest b/net-misc/mptcpd/Manifest
index 3e5be0c6a1a5..d43011bddb17 100644
--- a/net-misc/mptcpd/Manifest
+++ b/net-misc/mptcpd/Manifest
@@ -1 +1,2 @@
DIST mptcpd-0.10.tar.gz 671508 BLAKE2B de29050b5394b4011bf2bc25ce7ca33c42da8332e10d89c849047508886080e43e0e4f734e77437f8b0122336b47aa4f6442c07461e4552183cf10b08dfb6d81 SHA512 758dd9c84446abab7a26e6e7fa19fedb6ab4a8dbb8d6e2535f3eae5b9b423becaec9a18aea214498b424d110227af7eafb630b91b963eb5be2da0da936fd3a93
+DIST mptcpd-0.11.tar.gz 685987 BLAKE2B 70fa9cdf24116fad62f2527edca2fc4076541db533ac046d170975c011efdce4fb5341289f2825df3a9233f63c2bbdd172d2ea758d00cd19d473b1d9eea40fb0 SHA512 93f06e828365fd50fce17f4e9305891b2a6ef5e6cd40bff40bbfb614db8d7ff728455dcb23a1a53e5cb059f4dd5ff7a5dcee2cfe8b4cedab1bffc32c87b0e400
diff --git a/net-misc/mptcpd/mptcpd-0.11.ebuild b/net-misc/mptcpd/mptcpd-0.11.ebuild
new file mode 100644
index 000000000000..2ee9b4505be0
--- /dev/null
+++ b/net-misc/mptcpd/mptcpd-0.11.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info systemd
+
+DESCRIPTION="Daemon that performs multipath TCP path management related operations."
+HOMEPAGE="https://github.com/intel/mptcpd/"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="debug doc"
+
+RDEPEND="
+ >=dev-libs/ell-0.45.0
+ elibc_musl? ( sys-libs/argp-standalone )
+ "
+DEPEND="
+ ${RDEPEND}
+ >=sys-kernel/linux-headers-5.6
+ "
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ app-text/pandoc
+ )
+ virtual/pkgconfig
+ "
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/intel/mptcpd.git"
+else
+ SRC_URI="https://github.com/intel/mptcpd/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+CONFIG_CHECK="MPTCP"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9-no-werror.patch
+)
+
+src_prepare() {
+ default
+
+ # For Werror patch
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-kernel=upstream
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable debug)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+ use doc && emake doxygen-doc
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}