summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dropbear/dropbear-2022.82.ebuild1
-rw-r--r--net-misc/dropbear/files/dropbear-2022.82-x11.patch22
2 files changed, 23 insertions, 0 deletions
diff --git a/net-misc/dropbear/dropbear-2022.82.ebuild b/net-misc/dropbear/dropbear-2022.82.ebuild
index 27bbc8b51dd6..1df3c22e1a2c 100644
--- a/net-misc/dropbear/dropbear-2022.82.ebuild
+++ b/net-misc/dropbear/dropbear-2022.82.ebuild
@@ -45,6 +45,7 @@ REQUIRED_USE="pam? ( !static )"
PATCHES=(
"${FILESDIR}"/${PN}-0.46-dbscp.patch
+ "${FILESDIR}"/${PN}-2022.82-x11.patch
)
set_options() {
diff --git a/net-misc/dropbear/files/dropbear-2022.82-x11.patch b/net-misc/dropbear/files/dropbear-2022.82-x11.patch
new file mode 100644
index 000000000000..82cb9c812ebe
--- /dev/null
+++ b/net-misc/dropbear/files/dropbear-2022.82-x11.patch
@@ -0,0 +1,22 @@
+From 0292aacdf0aa57d03f2a3ab7e53cf650e6f29389 Mon Sep 17 00:00:00 2001
+From: Matt Johnston <matt@ucc.asn.au>
+Date: Sat, 23 Apr 2022 22:33:31 +0800
+Subject: [PATCH] Fix X11 build failure, use DROPBEAR_PRIO_LOWDELAY
+
+---
+ svr-x11fwd.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/svr-x11fwd.c b/svr-x11fwd.c
+index 353cb12e..5d9e6a96 100644
+--- a/svr-x11fwd.c
++++ b/svr-x11fwd.c
+@@ -206,7 +206,7 @@ void x11cleanup(struct ChanSess *chansess) {
+ }
+
+ static int x11_inithandler(struct Channel *channel) {
+- channel->prio = DROPBEAR_CHANNEL_PRIO_INTERACTIVE;
++ channel->prio = DROPBEAR_PRIO_LOWDELAY;
+ return 0;
+ }
+