summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/httpstat/files/httpstat-1.2.1-gentoo-tests.patch12
-rw-r--r--net-misc/httpstat/httpstat-1.3.1-r1.ebuild6
2 files changed, 9 insertions, 9 deletions
diff --git a/net-misc/httpstat/files/httpstat-1.2.1-gentoo-tests.patch b/net-misc/httpstat/files/httpstat-1.2.1-gentoo-tests.patch
index 0fcb6523e6e1..37985a3241a0 100644
--- a/net-misc/httpstat/files/httpstat-1.2.1-gentoo-tests.patch
+++ b/net-misc/httpstat/files/httpstat-1.2.1-gentoo-tests.patch
@@ -8,24 +8,24 @@
@@ -19,8 +19,7 @@ function title() {
http_url="google.com"
https_url="https://http2.akamai.com"
-
+
-for pybin in python python3; do
-#for pybin in python; do
-+for pybin in python; do
++for pybin in ${EPYTHON}; do
echo
echo "# Test in $pybin"
-
+
@@ -40,9 +39,9 @@ for pybin in python python3; do
main_silent $https_url
assert_exit 0
-
+
- title "comma decimal language (ru_RU)"
- LC_ALL=ru_RU main_silent $http_url
- assert_exit 0
+ #title "comma decimal language (ru_RU)"
+ #LC_ALL=ru_RU main_silent $http_url
+ #assert_exit 0
-
+
title "HTTPSTAT_DEBUG"
HTTPSTAT_DEBUG=true main $http_url | grep -q 'HTTPSTAT_DEBUG=true'
-
+
diff --git a/net-misc/httpstat/httpstat-1.3.1-r1.ebuild b/net-misc/httpstat/httpstat-1.3.1-r1.ebuild
index cdd345b94cba..7c8ead845af8 100644
--- a/net-misc/httpstat/httpstat-1.3.1-r1.ebuild
+++ b/net-misc/httpstat/httpstat-1.3.1-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1
DESCRIPTION="httpstat visualizes cURL statistics in a way of beauty and clarity"
@@ -24,5 +24,5 @@ PROPERTIES="test_network"
PATCHES=( "${FILESDIR}"/${PN}-1.2.1-gentoo-tests.patch )
python_test() {
- ./httpstat_test.sh || die
+ ./httpstat_test.sh || die "Tests failed with ${EPYTHON}"
}