summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.26.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index b0a47e1d0637..052f225f9880 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1 +1,2 @@
DIST gallery-dl-1.25.8.gh.tar.gz 570435 BLAKE2B 33cd558c0f30cc31adbd0a51365b9501309be001cb0f7a3bb83e21dc797ca7e097b94e1575e4c0342fad44a5fca07a486d1e44db1a12d90ade06d0bc4acf8384 SHA512 22bd9e330efe24cb56e7b9b3eb219094aa897bb620253c4dd3fcda33df82fc021f1151dd9a6aff1f762c3ed4d426aadc75a398a659b30f64f254780554f46687
+DIST gallery-dl-1.26.0.gh.tar.gz 597078 BLAKE2B 7fa140babb63d288c3ebf6ff01a4384fcea5885b4355ed17300b985b29b7897f644ffafeed268553be0660ab5efd5343d665cc13dbed6141f171ee01e9a2a2f6 SHA512 bbefacf137cad2518eff996a357a0803cf40519fbfcd762af0885e6cb791ec5abe3139e6fb23972d447d6d656ff184d16933659468e047afc52f52c78a4cacdd
diff --git a/net-misc/gallery-dl/gallery-dl-1.26.0.ebuild b/net-misc/gallery-dl/gallery-dl-1.26.0.ebuild
new file mode 100644
index 000000000000..b3da2a9c870f
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.26.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# Tests require network access.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}