summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/cadaver/cadaver-0.23.3.ebuild18
-rw-r--r--net-misc/cadaver/files/cadaver-0.23.2-disable-nls.patch8
2 files changed, 12 insertions, 14 deletions
diff --git a/net-misc/cadaver/cadaver-0.23.3.ebuild b/net-misc/cadaver/cadaver-0.23.3.ebuild
index 89897109b85e..0401ea0f0cac 100644
--- a/net-misc/cadaver/cadaver-0.23.3.ebuild
+++ b/net-misc/cadaver/cadaver-0.23.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
+EAPI="6"
-inherit autotools eutils
+inherit autotools
DESCRIPTION="Command-line WebDAV client"
HOMEPAGE="http://www.webdav.org/cadaver"
@@ -18,10 +18,13 @@ RDEPEND=">=net-libs/neon-0.27.0"
DEPEND="${RDEPEND}
sys-devel/gettext"
+DOCS=(BUGS ChangeLog FAQ NEWS README THANKS TODO)
+
src_prepare() {
- epatch "${FILESDIR}/${PN}-0.23.2-disable-nls.patch"
+ eapply "${FILESDIR}/${PN}-0.23.2-disable-nls.patch"
+ eapply_user
- rm -fr lib/{expat,intl,neon}
+ rm -r lib/{expat,intl,neon} || die "rm failed"
sed \
-e "/NE_REQUIRE_VERSIONS/s/29/& 30/" \
-e "s:lib/neon/Makefile lib/intl/Makefile ::" \
@@ -37,8 +40,3 @@ src_configure() {
$(use_enable nls) \
--with-libs=/usr
}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc BUGS ChangeLog FAQ NEWS README THANKS TODO
-}
diff --git a/net-misc/cadaver/files/cadaver-0.23.2-disable-nls.patch b/net-misc/cadaver/files/cadaver-0.23.2-disable-nls.patch
index 6610d479b30d..ead3d70553b8 100644
--- a/net-misc/cadaver/files/cadaver-0.23.2-disable-nls.patch
+++ b/net-misc/cadaver/files/cadaver-0.23.2-disable-nls.patch
@@ -1,12 +1,12 @@
Fix building with --disable-nls.
---- src/cadaver.c.~1~ 2007-08-22 14:17:27.000000000 +0200
-+++ src/cadaver.c 2008-03-29 08:58:57.248793293 +0100
-@@ -838,11 +838,12 @@
+
+--- /src/cadaver.c
++++ /src/cadaver.c
+@@ -838,11 +838,11 @@
progname = argv[0];
+#ifdef ENABLE_NLS
-+
#ifdef HAVE_SETLOCALE
setlocale(LC_ALL, "");
#endif