summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/unison/unison-2.48.15_p4-r1.ebuild (renamed from net-misc/unison/unison-2.48.15_p4.ebuild)4
-rw-r--r--net-misc/unison/unison-2.51.3_rc3.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/net-misc/unison/unison-2.48.15_p4.ebuild b/net-misc/unison/unison-2.48.15_p4-r1.ebuild
index e32810067cdd..d8102533b702 100644
--- a/net-misc/unison/unison-2.48.15_p4.ebuild
+++ b/net-misc/unison/unison-2.48.15_p4-r1.ebuild
@@ -41,7 +41,7 @@ PATCHES=(
DOCS=( BUGS.txt CONTRIB INSTALL NEWS README ROADMAP.txt TODO.txt )
src_compile() {
- local myconf
+ local myconf="all"
if use threads; then
myconf="$myconf THREADS=true"
@@ -77,7 +77,7 @@ src_install() {
if use gtk; then
newicon -s scalable ../icons/U.svg ${PN}-${SLOT}.svg
- make_desktop_entry Unison "${PN} (${SLOT})" "${EPREFIX}/usr/share/${PN}/${PN}-${SLOT}.svg"
+ make_desktop_entry unison-${SLOT} "${PN} (${SLOT})" "${EPREFIX}/usr/share/${PN}/${PN}-${SLOT}.svg"
fi
# No manual.pdf or manual.html available for this version
diff --git a/net-misc/unison/unison-2.51.3_rc3.ebuild b/net-misc/unison/unison-2.51.3_rc3.ebuild
index 8b324830c1e4..314ce0d4d1cb 100644
--- a/net-misc/unison/unison-2.51.3_rc3.ebuild
+++ b/net-misc/unison/unison-2.51.3_rc3.ebuild
@@ -32,7 +32,7 @@ RDEPEND="
DOCS=( BUGS.txt CONTRIB INSTALL NEWS README ROADMAP.txt TODO.txt )
src_compile() {
- local myconf
+ local myconf="all"
if use threads; then
myconf="$myconf THREADS=true"
@@ -69,7 +69,7 @@ src_install() {
if use gtk; then
newicon -s scalable ../icons/U.svg ${PN}-${SLOT}.svg
- make_desktop_entry Unison "${PN} (${SLOT})" "${EPREFIX}/usr/share/${PN}/${PN}-${SLOT}.svg"
+ make_desktop_entry unison-${SLOT} "${PN} (${SLOT})" "${EPREFIX}/usr/share/${PN}/${PN}-${SLOT}.svg"
fi
# No docs for release candidates