summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rdesktop/Manifest1
-rw-r--r--net-misc/rdesktop/files/rdesktop-1.7.0-libao_crash.patch18
-rw-r--r--net-misc/rdesktop/files/rdesktop-1.8.3-openssl-1.1.patch125
-rw-r--r--net-misc/rdesktop/rdesktop-1.8.3-r1.ebuild74
-rw-r--r--net-misc/rdesktop/rdesktop-1.8.3-r2.ebuild76
-rw-r--r--net-misc/rdesktop/rdesktop-1.8.3-r3.ebuild70
-rw-r--r--net-misc/rdesktop/rdesktop-1.8.3.ebuild74
-rw-r--r--net-misc/rdesktop/rdesktop-1.8.4.ebuild69
8 files changed, 0 insertions, 507 deletions
diff --git a/net-misc/rdesktop/Manifest b/net-misc/rdesktop/Manifest
index ba8eea641aa7..4e04d7702124 100644
--- a/net-misc/rdesktop/Manifest
+++ b/net-misc/rdesktop/Manifest
@@ -1,2 +1 @@
-DIST rdesktop-1.8.3.tar.gz 320212 BLAKE2B daca0b78a8fcd0461f1c3251135bd980aaafacf8e0cd51ab731b576adb23006ec9f51858586e7e3a1a7f192b7830308e585984b4a31fb013748f8c6b3a8c47bb SHA512 06b94ad3b09430b05e424ef31a3e6f2388190b4920e348603cb66a414244896e0dc8906b9f12920e9406cf153ffa7f6507b23bf6713c3a675c0540a8ef57902d
DIST rdesktop-1.8.4.tar.gz 321448 BLAKE2B b4d5a91f77a63258d08823c860b2d7045b0ee7ad0feb144746c904146c410c6456391eb3f2b7b9a6a40c2fb34515bb7518888c2c9da8dfcaf17c5309ff21cad3 SHA512 9e4f6723eb0baab31ad11f1c5c29a4753c655386c2381d01646b7834c959ffc2ec1e0c2f3f73626255aa018889709758d97387c7563da98bb1b7f269610929ae
diff --git a/net-misc/rdesktop/files/rdesktop-1.7.0-libao_crash.patch b/net-misc/rdesktop/files/rdesktop-1.7.0-libao_crash.patch
deleted file mode 100644
index 3afb9b2b0f23..000000000000
--- a/net-misc/rdesktop/files/rdesktop-1.7.0-libao_crash.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- rdpsnd_libao.c.orig 2010-11-29 14:55:31.124907038 +0100
-+++ rdpsnd_libao.c 2010-11-29 14:55:51.708464083 +0100
-@@ -76,6 +76,7 @@
- format.channels = 2;
- format.rate = 44100;
- format.byte_format = AO_FMT_NATIVE;
-+ format.matrix = NULL;
-
-
- o_device = ao_open_live(default_driver, &format, NULL);
-@@ -115,6 +116,7 @@
- format.channels = pwfx->nChannels;
- format.rate = 44100;
- format.byte_format = AO_FMT_NATIVE;
-+ format.matrix = NULL;
-
- if (o_device != NULL)
- ao_close(o_device);
diff --git a/net-misc/rdesktop/files/rdesktop-1.8.3-openssl-1.1.patch b/net-misc/rdesktop/files/rdesktop-1.8.3-openssl-1.1.patch
deleted file mode 100644
index c74bd48c5aa0..000000000000
--- a/net-misc/rdesktop/files/rdesktop-1.8.3-openssl-1.1.patch
+++ /dev/null
@@ -1,125 +0,0 @@
-From bd6aa6acddf0ba640a49834807872f4cc0d0a773 Mon Sep 17 00:00:00 2001
-From: Jani Hakala <jjhakala@gmail.com>
-Date: Thu, 16 Jun 2016 14:28:15 +0300
-Subject: [PATCH] Fix OpenSSL 1.1 compability issues
-
-Some data types have been made opaque in OpenSSL version 1.1 so
-stack allocation and accessing struct fields directly does not work.
----
- ssl.c | 65 ++++++++++++++++++++++++++++++++++++-----------------------
- 1 file changed, 40 insertions(+), 25 deletions(-)
-
-diff --git a/ssl.c b/ssl.c
-index 48751255..032e9b9e 100644
---- a/ssl.c
-+++ b/ssl.c
-@@ -88,7 +88,7 @@ rdssl_rsa_encrypt(uint8 * out, uint8 * in, int len, uint32 modulus_size, uint8 *
- uint8 * exponent)
- {
- BN_CTX *ctx;
-- BIGNUM mod, exp, x, y;
-+ BIGNUM *mod, *exp, *x, *y;
- uint8 inr[SEC_MAX_MODULUS_SIZE];
- int outlen;
-
-@@ -98,24 +98,24 @@ rdssl_rsa_encrypt(uint8 * out, uint8 * in, int len, uint32 modulus_size, uint8 *
- reverse(inr, len);
-
- ctx = BN_CTX_new();
-- BN_init(&mod);
-- BN_init(&exp);
-- BN_init(&x);
-- BN_init(&y);
--
-- BN_bin2bn(modulus, modulus_size, &mod);
-- BN_bin2bn(exponent, SEC_EXPONENT_SIZE, &exp);
-- BN_bin2bn(inr, len, &x);
-- BN_mod_exp(&y, &x, &exp, &mod, ctx);
-- outlen = BN_bn2bin(&y, out);
-+ mod = BN_new();
-+ exp = BN_new();
-+ x = BN_new();
-+ y = BN_new();
-+
-+ BN_bin2bn(modulus, modulus_size, mod);
-+ BN_bin2bn(exponent, SEC_EXPONENT_SIZE, exp);
-+ BN_bin2bn(inr, len, x);
-+ BN_mod_exp(y, x, exp, mod, ctx);
-+ outlen = BN_bn2bin(y, out);
- reverse(out, outlen);
- if (outlen < (int) modulus_size)
- memset(out + outlen, 0, modulus_size - outlen);
-
-- BN_free(&y);
-- BN_clear_free(&x);
-- BN_free(&exp);
-- BN_free(&mod);
-+ BN_free(y);
-+ BN_clear_free(x);
-+ BN_free(exp);
-+ BN_free(mod);
- BN_CTX_free(ctx);
- }
-
-@@ -146,12 +146,20 @@ rdssl_cert_to_rkey(RDSSL_CERT * cert, uint32 * key_len)
-
- Kudos to Richard Levitte for the following (. intiutive .)
- lines of code that resets the OID and let's us extract the key. */
-- nid = OBJ_obj2nid(cert->cert_info->key->algor->algorithm);
-+
-+ X509_PUBKEY *key = NULL;
-+ X509_ALGOR *algor = NULL;
-+
-+ key = X509_get_X509_PUBKEY(cert);
-+ algor = X509_PUBKEY_get0_param(NULL, NULL, 0, &algor, key);
-+
-+ nid = OBJ_obj2nid(algor->algorithm);
-+
- if ((nid == NID_md5WithRSAEncryption) || (nid == NID_shaWithRSAEncryption))
- {
- DEBUG_RDP5(("Re-setting algorithm type to RSA in server certificate\n"));
-- ASN1_OBJECT_free(cert->cert_info->key->algor->algorithm);
-- cert->cert_info->key->algor->algorithm = OBJ_nid2obj(NID_rsaEncryption);
-+ X509_PUBKEY_set0_param(key, OBJ_nid2obj(NID_rsaEncryption),
-+ 0, NULL, NULL, 0);
- }
- epk = X509_get_pubkey(cert);
- if (NULL == epk)
-@@ -201,14 +209,24 @@ rdssl_rkey_get_exp_mod(RDSSL_RKEY * rkey, uint8 * exponent, uint32 max_exp_len,
- {
- int len;
-
-- if ((BN_num_bytes(rkey->e) > (int) max_exp_len) ||
-- (BN_num_bytes(rkey->n) > (int) max_mod_len))
-+ BIGNUM *e = NULL;
-+ BIGNUM *n = NULL;
-+
-+#if (OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER))
-+ e = rkey->e;
-+ n = rkey->n;
-+#else
-+ RSA_get0_key(rkey, &e, &n, NULL);
-+#endif
-+
-+ if ((BN_num_bytes(e) > (int) max_exp_len) ||
-+ (BN_num_bytes(n) > (int) max_mod_len))
- {
- return 1;
- }
-- len = BN_bn2bin(rkey->e, exponent);
-+ len = BN_bn2bin(e, exponent);
- reverse(exponent, len);
-- len = BN_bn2bin(rkey->n, modulus);
-+ len = BN_bn2bin(n, modulus);
- reverse(modulus, len);
- return 0;
- }
-@@ -229,8 +247,5 @@ void
- rdssl_hmac_md5(const void *key, int key_len, const unsigned char *msg, int msg_len,
- unsigned char *md)
- {
-- HMAC_CTX ctx;
-- HMAC_CTX_init(&ctx);
- HMAC(EVP_md5(), key, key_len, msg, msg_len, md, NULL);
-- HMAC_CTX_cleanup(&ctx);
- }
diff --git a/net-misc/rdesktop/rdesktop-1.8.3-r1.ebuild b/net-misc/rdesktop/rdesktop-1.8.3-r1.ebuild
deleted file mode 100644
index 57610b0cc2cc..000000000000
--- a/net-misc/rdesktop/rdesktop-1.8.3-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils
-
-MY_PV=${PV/_/-}
-
-DESCRIPTION="A Remote Desktop Protocol Client"
-HOMEPAGE="http://rdesktop.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="alsa ao debug ipv6 kerberos libsamplerate oss pcsc-lite xrandr"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-RDEPEND=">=dev-libs/openssl-0.9.6b:=
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXau
- x11-libs/libXdmcp
- alsa? ( media-libs/alsa-lib )
- ao? ( >=media-libs/libao-0.8.6 )
- kerberos? ( net-libs/libgssglue )
- libsamplerate? ( media-libs/libsamplerate )
- pcsc-lite? ( >=sys-apps/pcsc-lite-1.6.6 )
- xrandr? ( x11-libs/libXrandr )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- x11-libs/libXt"
-
-src_prepare() {
- # Prevent automatic stripping
- local strip="$(echo '$(STRIP) $(DESTDIR)$(bindir)/rdesktop')"
- sed -i -e "s:${strip}::" Makefile.in \
- || die "sed failed in Makefile.in"
-
- # Automagic dependencies
- epatch "${FILESDIR}"/${PN}-1.6.0-sound_configure.patch
- epatch "${FILESDIR}"/${P}-xrandr_configure.patch
-
- epatch_user
-
- eautoreconf
-}
-
-src_configure() {
- if use ao; then
- sound_conf=$(use_with ao sound libao)
- else if use alsa; then
- sound_conf=$(use_with alsa sound alsa)
- else
- sound_conf=$(use_with oss sound oss)
- fi
- fi
-
- econf \
- --with-openssl="${EPREFIX}"/usr \
- $(use_with debug) \
- $(use_with ipv6) \
- $(use_with libsamplerate) \
- $(use_with xrandr) \
- $(use_enable kerberos credssp) \
- $(use_enable pcsc-lite smartcard) \
- ${sound_conf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc doc/HACKING doc/TODO doc/keymapping.txt
-}
diff --git a/net-misc/rdesktop/rdesktop-1.8.3-r2.ebuild b/net-misc/rdesktop/rdesktop-1.8.3-r2.ebuild
deleted file mode 100644
index 5598e930762a..000000000000
--- a/net-misc/rdesktop/rdesktop-1.8.3-r2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils
-
-MY_PV=${PV/_/-}
-
-DESCRIPTION="A Remote Desktop Protocol Client"
-HOMEPAGE="http://rdesktop.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="alsa ao debug ipv6 kerberos libressl libsamplerate oss pcsc-lite xrandr"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-RDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:= )
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXau
- x11-libs/libXdmcp
- alsa? ( media-libs/alsa-lib )
- ao? ( >=media-libs/libao-0.8.6 )
- kerberos? ( net-libs/libgssglue )
- libsamplerate? ( media-libs/libsamplerate )
- pcsc-lite? ( >=sys-apps/pcsc-lite-1.6.6 )
- xrandr? ( x11-libs/libXrandr )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- x11-libs/libXt"
-
-src_prepare() {
- # Prevent automatic stripping
- local strip="$(echo '$(STRIP) $(DESTDIR)$(bindir)/rdesktop')"
- sed -i -e "s:${strip}::" Makefile.in \
- || die "sed failed in Makefile.in"
-
- # Automagic dependencies
- epatch "${FILESDIR}"/${PN}-1.6.0-sound_configure.patch
- epatch "${FILESDIR}"/${P}-xrandr_configure.patch
-
- epatch_user
-
- eautoreconf
-}
-
-src_configure() {
- if use ao; then
- sound_conf=$(use_with ao sound libao)
- else if use alsa; then
- sound_conf=$(use_with alsa sound alsa)
- else
- sound_conf=$(use_with oss sound oss)
- fi
- fi
-
- econf \
- --with-openssl="${EPREFIX}"/usr \
- $(use_with debug) \
- $(use_with ipv6) \
- $(use_with libsamplerate) \
- $(use_with xrandr) \
- $(use_enable kerberos credssp) \
- $(use_enable pcsc-lite smartcard) \
- ${sound_conf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc doc/HACKING doc/TODO doc/keymapping.txt
-}
diff --git a/net-misc/rdesktop/rdesktop-1.8.3-r3.ebuild b/net-misc/rdesktop/rdesktop-1.8.3-r3.ebuild
deleted file mode 100644
index 1d73ffcf64a2..000000000000
--- a/net-misc/rdesktop/rdesktop-1.8.3-r3.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools eutils
-
-MY_PV=${PV/_/-}
-
-DESCRIPTION="A Remote Desktop Protocol Client"
-HOMEPAGE="http://rdesktop.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="alsa ao debug ipv6 kerberos libressl libsamplerate oss pcsc-lite xrandr"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-RDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:= )
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXau
- x11-libs/libXdmcp
- alsa? ( media-libs/alsa-lib )
- ao? ( >=media-libs/libao-0.8.6 )
- kerberos? ( net-libs/libgssglue )
- libsamplerate? ( media-libs/libsamplerate )
- pcsc-lite? ( >=sys-apps/pcsc-lite-1.6.6 )
- xrandr? ( x11-libs/libXrandr )"
-DEPEND="${RDEPEND}
- x11-libs/libXt"
-BDEPEND=virtual/pkgconfig
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.6.0-sound_configure.patch
- "${FILESDIR}"/${P}-no_strip.patch
- "${FILESDIR}"/${P}-xrandr_configure.patch
- "${FILESDIR}"/${P}-openssl-1.1.patch
-)
-
-DOCS=( doc/HACKING doc/TODO doc/keymapping.txt )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- if use ao; then
- sound_conf=$(use_with ao sound libao)
- else if use alsa; then
- sound_conf=$(use_with alsa sound alsa)
- else
- sound_conf=$(use_with oss sound oss)
- fi
- fi
-
- econf \
- --with-openssl="${EPREFIX}"/usr \
- $(use_with debug) \
- $(use_with ipv6) \
- $(use_with libsamplerate) \
- $(use_with xrandr) \
- $(use_enable kerberos credssp) \
- $(use_enable pcsc-lite smartcard) \
- ${sound_conf}
-}
diff --git a/net-misc/rdesktop/rdesktop-1.8.3.ebuild b/net-misc/rdesktop/rdesktop-1.8.3.ebuild
deleted file mode 100644
index 1e898da2e7ae..000000000000
--- a/net-misc/rdesktop/rdesktop-1.8.3.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools eutils
-
-MY_PV=${PV/_/-}
-
-DESCRIPTION="A Remote Desktop Protocol Client"
-HOMEPAGE="http://rdesktop.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="alsa ao debug ipv6 kerberos libsamplerate oss pcsc-lite"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-RDEPEND=">=dev-libs/openssl-0.9.6b
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXau
- x11-libs/libXdmcp
- alsa? ( media-libs/alsa-lib )
- ao? ( >=media-libs/libao-0.8.6 )
- kerberos? ( net-libs/libgssglue )
- libsamplerate? ( media-libs/libsamplerate )
- pcsc-lite? ( >=sys-apps/pcsc-lite-1.6.6 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- x11-libs/libXt"
-
-src_prepare() {
- # Prevent automatic stripping
- local strip="$(echo '$(STRIP) $(DESTDIR)$(bindir)/rdesktop')"
- sed -i -e "s:${strip}::" Makefile.in \
- || die "sed failed in Makefile.in"
-
- # Automagic dependency on libsamplerate
- epatch "${FILESDIR}"/${PN}-1.6.0-sound_configure.patch
- # bug #280923
- epatch "${FILESDIR}"/${PN}-1.7.0-libao_crash.patch
-
- epatch_user
-
- eautoreconf
-}
-
-src_configure() {
- if use ao; then
- sound_conf=$(use_with ao sound libao)
- else if use alsa; then
- sound_conf=$(use_with alsa sound alsa)
- else
- sound_conf=$(use_with oss sound oss)
- fi
- fi
-
- econf \
- --with-openssl="${EPREFIX}"/usr \
- $(use_with debug) \
- $(use_with ipv6) \
- $(use_with libsamplerate) \
- $(use_enable kerberos credssp) \
- $(use_enable pcsc-lite smartcard) \
- ${sound_conf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc doc/HACKING doc/TODO doc/keymapping.txt
-}
diff --git a/net-misc/rdesktop/rdesktop-1.8.4.ebuild b/net-misc/rdesktop/rdesktop-1.8.4.ebuild
deleted file mode 100644
index f5be6057df98..000000000000
--- a/net-misc/rdesktop/rdesktop-1.8.4.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools eutils
-
-MY_PV=${PV/_/-}
-
-DESCRIPTION="A Remote Desktop Protocol Client"
-HOMEPAGE="http://www.rdesktop.org/"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="alsa ao debug ipv6 kerberos libressl libsamplerate oss pcsc-lite xrandr"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-RDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:= )
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXau
- x11-libs/libXdmcp
- alsa? ( media-libs/alsa-lib )
- ao? ( >=media-libs/libao-0.8.6 )
- kerberos? ( net-libs/libgssglue )
- libsamplerate? ( media-libs/libsamplerate )
- pcsc-lite? ( >=sys-apps/pcsc-lite-1.6.6 )
- xrandr? ( x11-libs/libXrandr )"
-DEPEND="${RDEPEND}
- x11-libs/libXt"
-BDEPEND=virtual/pkgconfig
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.6.0-sound_configure.patch
- "${FILESDIR}"/${PN}-1.8.3-no_strip.patch
- "${FILESDIR}"/${PN}-1.8.3-xrandr_configure.patch
-)
-
-DOCS=( doc/HACKING doc/TODO doc/keymapping.txt )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- if use ao; then
- sound_conf=$(use_with ao sound libao)
- else if use alsa; then
- sound_conf=$(use_with alsa sound alsa)
- else
- sound_conf=$(use_with oss sound oss)
- fi
- fi
-
- econf \
- --with-openssl="${EPREFIX}"/usr \
- $(use_with debug) \
- $(use_with ipv6) \
- $(use_with libsamplerate) \
- $(use_with xrandr) \
- $(use_enable kerberos credssp) \
- $(use_enable pcsc-lite smartcard) \
- ${sound_conf}
-}