summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nntp/tin')
-rw-r--r--net-nntp/tin/Manifest3
-rw-r--r--net-nntp/tin/metadata.xml12
-rw-r--r--net-nntp/tin/tin-2.0.1-r1.ebuild95
-rw-r--r--net-nntp/tin/tin-2.2.1.ebuild93
-rw-r--r--net-nntp/tin/tin-2.3.1.ebuild93
5 files changed, 296 insertions, 0 deletions
diff --git a/net-nntp/tin/Manifest b/net-nntp/tin/Manifest
new file mode 100644
index 000000000000..70726ba7d820
--- /dev/null
+++ b/net-nntp/tin/Manifest
@@ -0,0 +1,3 @@
+DIST tin-2.0.1.tar.bz2 1758848 SHA256 eb4c1e46defb66f02eb64daa0929414c6363d9d4d74ec2458cfc6e781de89b1f SHA512 fc2bd0586e72a2fb4f8a223c0ceeb19e2dfcdb300d463f0f5d4b7367346a032614aa662a4d9d11673269be59cbaeff39fa3fdf7618dd41e965850d137919a386 WHIRLPOOL 1e565e2e6e3f02d2e77ef382066df81fc29ff59691d5defd7752c2bb158fa85207f9a619fd40948ea6a3a5b51caa57638a720ecab40b83de2a6af706a40bc0d2
+DIST tin-2.2.1.tar.xz 1378384 SHA256 a9968d4b43e2faa4ca1f27e5f2211fa261b2884846c909f59aa76cdaa955ddc7 SHA512 2c5b4b50be38c168404ba55c9429355c0dd2232c580116086fa9ea24a8907ad2d71d91b2d1c533bf7ff4d24fd1946d5ba61bc0833b20d5383e013e2f18c10bbd WHIRLPOOL a6cb1674c497e1a08b93d19a508d070635893795a4298f1b04cc35a4254ae88eb27dc4bd1b84d3fbfe56a59d3656ee325777248e832f091d0cd0da83b4fbfd4c
+DIST tin-2.3.1.tar.xz 1381840 SHA256 7d9069fe567f4309ac26dff5334a3c4365c4d2097929a2d47846628e4d8644c6 SHA512 53fecc8fca7c67a7082a1f3f77a868433725a2ad4cc5650cdd522f791cbfc336733db5de3c637606788a2844df7e13e1d3fbae48c15ceaa49e24ea6e297926af WHIRLPOOL f7c0ba02ce4695823b1601f516af305e148de05f345f733d1ef7bbd81c996fe2740e913f32918b5af4e956f25e81c71f943d78906a25df22974f11ba79531a04
diff --git a/net-nntp/tin/metadata.xml b/net-nntp/tin/metadata.xml
new file mode 100644
index 000000000000..65301ea853c4
--- /dev/null
+++ b/net-nntp/tin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-news</herd>
+<use>
+<flag name='cancel-locks'>Enable Cancel-Lock header functionality (also enables USE=evil)</flag>
+<flag name='evil'>Let tin generate a message ID</flag>
+<flag name='forgery'>Cancel messages posted from a different account</flag>
+<flag name='gpg'>Enable <pkg>app-crypt/gpg</pkg> support</flag>
+<flag name='etiquette'>Enable the display off posting etiquettes</flag>
+</use>
+</pkgmetadata>
diff --git a/net-nntp/tin/tin-2.0.1-r1.ebuild b/net-nntp/tin/tin-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..86103571f9ed
--- /dev/null
+++ b/net-nntp/tin/tin-2.0.1-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils toolchain-funcs versionator
+
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+HOMEPAGE="http://www.tin.org/"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/v$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cancel-locks debug doc +etiquette evil forgery gpg idn ipv6 mime nls sasl socks5 spell unicode"
+
+RDEPEND="
+ dev-libs/libpcre
+ dev-libs/uulib
+ gpg? ( app-crypt/gnupg )
+ idn? ( net-dns/libidn )
+ mime? ( net-mail/metamail )
+ net-misc/urlview
+ nls? ( sys-devel/gettext )
+ sasl? ( virtual/gsasl )
+ socks5? ( net-proxy/dante )
+ sys-libs/ncurses[unicode?]
+ unicode? ( dev-libs/icu:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not strip
+ sed -i src/Makefile.in -e '388s|-s ||g' || die "sed src/Makefile.in failed"
+ sed -i configure.in -e '/CFLAGS/s|-g||g' || die
+ eautoreconf
+}
+
+src_configure() {
+ if use evil || use cancel-locks; then
+ sed -i -e"s/# -DEVIL_INSIDE/-DEVIL_INSIDE/" src/Makefile.in
+ fi
+
+ if use forgery
+ then
+ sed -i -e"s/^CPPFLAGS.*/& -DFORGERY/" src/Makefile.in
+ fi
+
+ local screen="ncurses"
+ use unicode && screen="ncursesw"
+
+ use etiquette || myconf="${myconf} --disable-etiquette"
+
+ tc-export AR CC RANLIB
+
+ econf \
+ $(use_enable cancel-locks) \
+ $(use_enable debug) \
+ $(use_enable gpg pgp-gpg) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_with mime metamail /usr) \
+ $(use_with socks5 socks) $(use_with socks5) \
+ $(use_with spell ispell /usr) \
+ --disable-mime-strict-charset \
+ --enable-echo \
+ --enable-nntp-only \
+ --enable-prototypes \
+ --with-coffee \
+ --with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.org}}" \
+ --with-pcre=/usr \
+ --with-screen=${screen} \
+ ${myconf}
+}
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ default
+
+ # File collision?
+ rm -f "${ED}"/usr/share/man/man5/{mbox,mmdf}.5
+
+ dodoc doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW}
+ use doc && dodoc doc/{*.sample,*.txt}
+
+ insinto /etc/tin
+ doins doc/tin.defaults
+}
diff --git a/net-nntp/tin/tin-2.2.1.ebuild b/net-nntp/tin/tin-2.2.1.ebuild
new file mode 100644
index 000000000000..c4e719ba599f
--- /dev/null
+++ b/net-nntp/tin/tin-2.2.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs versionator
+
+TIN_PV=$(get_version_component_range 1-2)
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+HOMEPAGE="http://www.tin.org/"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/v${TIN_PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cancel-locks debug doc +etiquette evil forgery gpg idn ipv6 mime nls sasl socks5 spell unicode"
+
+RDEPEND="
+ dev-libs/libpcre
+ dev-libs/uulib
+ gpg? ( app-crypt/gnupg )
+ idn? ( net-dns/libidn )
+ mime? ( net-mail/metamail )
+ net-misc/urlview
+ nls? ( sys-devel/gettext )
+ sasl? ( virtual/gsasl )
+ socks5? ( net-proxy/dante )
+ sys-libs/ncurses[unicode?]
+ unicode? ( dev-libs/icu:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i src/Makefile.in -e 's| -s | |g' || die
+ sed -i configure -e '/CFLAGS/s|-g||g' || die
+}
+
+src_configure() {
+ if use evil || use cancel-locks; then
+ sed -i -e"s/# -DEVIL_INSIDE/-DEVIL_INSIDE/" src/Makefile.in
+ fi
+
+ if use forgery
+ then
+ sed -i -e"s/^CPPFLAGS.*/& -DFORGERY/" src/Makefile.in
+ fi
+
+ local screen="ncurses"
+ use unicode && screen="ncursesw"
+
+ tc-export AR CC RANLIB
+
+ econf \
+ $(use_enable cancel-locks) \
+ $(use_enable debug) \
+ $(use_enable etiquette) \
+ $(use_enable gpg pgp-gpg) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_with mime metamail /usr) \
+ $(use_with socks5 socks) $(use_with socks5) \
+ $(use_with spell ispell /usr) \
+ --disable-mime-strict-charset \
+ --enable-echo \
+ --enable-nntp-only \
+ --enable-prototypes \
+ --with-coffee \
+ --with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.org}}" \
+ --with-pcre=/usr \
+ --with-screen=${screen}
+}
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ default
+
+ # File collision?
+ rm -f "${ED}"/usr/share/man/man5/{mbox,mmdf}.5
+
+ dodoc doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW}
+ use doc && dodoc doc/{*.sample,*.txt}
+
+ insinto /etc/tin
+ doins doc/tin.defaults
+}
diff --git a/net-nntp/tin/tin-2.3.1.ebuild b/net-nntp/tin/tin-2.3.1.ebuild
new file mode 100644
index 000000000000..45b4e61ba327
--- /dev/null
+++ b/net-nntp/tin/tin-2.3.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs versionator
+
+TIN_PV=$(get_version_component_range 1-2)
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+HOMEPAGE="http://www.tin.org/"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/v${TIN_PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cancel-locks debug doc +etiquette evil forgery gpg idn ipv6 mime nls sasl socks5 spell unicode"
+
+RDEPEND="
+ dev-libs/libpcre
+ dev-libs/uulib
+ gpg? ( app-crypt/gnupg )
+ idn? ( net-dns/libidn )
+ mime? ( net-mail/metamail )
+ net-misc/urlview
+ nls? ( sys-devel/gettext )
+ sasl? ( virtual/gsasl )
+ socks5? ( net-proxy/dante )
+ sys-libs/ncurses[unicode?]
+ unicode? ( dev-libs/icu:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i src/Makefile.in -e 's| -s | |g' || die
+ sed -i configure -e '/CFLAGS/s|-g||g' || die
+}
+
+src_configure() {
+ if use evil || use cancel-locks; then
+ sed -i -e"s/# -DEVIL_INSIDE/-DEVIL_INSIDE/" src/Makefile.in
+ fi
+
+ if use forgery
+ then
+ sed -i -e"s/^CPPFLAGS.*/& -DFORGERY/" src/Makefile.in
+ fi
+
+ local screen="ncurses"
+ use unicode && screen="ncursesw"
+
+ tc-export AR CC RANLIB
+
+ econf \
+ $(use_enable cancel-locks) \
+ $(use_enable debug) \
+ $(use_enable etiquette) \
+ $(use_enable gpg pgp-gpg) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_with mime metamail /usr) \
+ $(use_with socks5 socks) $(use_with socks5) \
+ $(use_with spell ispell /usr) \
+ --disable-mime-strict-charset \
+ --enable-echo \
+ --enable-nntp-only \
+ --enable-prototypes \
+ --with-coffee \
+ --with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.org}}" \
+ --with-pcre=/usr \
+ --with-screen=${screen}
+}
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ default
+
+ # File collision?
+ rm -f "${ED}"/usr/share/man/man5/{mbox,mmdf}.5
+
+ dodoc doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW}
+ use doc && dodoc doc/{*.sample,*.txt}
+
+ insinto /etc/tin
+ doins doc/tin.defaults
+}