summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/inn/inn-2.5.3-r1.ebuild8
-rw-r--r--net-nntp/inn/inn-2.5.3-r3.ebuild8
-rw-r--r--net-nntp/inn/inn-2.5.4-r1.ebuild8
-rw-r--r--net-nntp/inn/inn-2.5.5-r1.ebuild8
4 files changed, 17 insertions, 15 deletions
diff --git a/net-nntp/inn/inn-2.5.3-r1.ebuild b/net-nntp/inn/inn-2.5.3-r1.ebuild
index fde86c2c99fd..48edc30bd817 100644
--- a/net-nntp/inn/inn-2.5.3-r1.ebuild
+++ b/net-nntp/inn/inn-2.5.3-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
inherit autotools eutils multilib python-single-r1 ssl-cert
@@ -15,6 +16,7 @@ LICENSE="ISC GPL-2+ public-domain BSD-4 BSD-2 RSA BSD MIT GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="berkdb innkeywords inntaggedhash ipv6 kerberos perl python sasl ssl"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="
virtual/mta
@@ -23,9 +25,9 @@ DEPEND="
sys-libs/zlib
kerberos? ( virtual/krb5 )
sasl? ( >=dev-libs/cyrus-sasl-2 )
- ssl? ( dev-libs/openssl )
+ ssl? ( dev-libs/openssl:0= )
python? ( ${PYTHON_DEPS} )
- berkdb? ( sys-libs/db )
+ berkdb? ( sys-libs/db:* )
"
RDEPEND="${DEPEND}"
diff --git a/net-nntp/inn/inn-2.5.3-r3.ebuild b/net-nntp/inn/inn-2.5.3-r3.ebuild
index c4801fe896c6..e356b6892f48 100644
--- a/net-nntp/inn/inn-2.5.3-r3.ebuild
+++ b/net-nntp/inn/inn-2.5.3-r3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
inherit autotools eutils multilib python-single-r1 ssl-cert toolchain-funcs
@@ -15,7 +16,6 @@ LICENSE="ISC GPL-2+ public-domain BSD-4 BSD-2 RSA BSD MIT GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="berkdb innkeywords inntaggedhash ipv6 kerberos perl python sasl ssl"
-
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="
@@ -25,9 +25,9 @@ DEPEND="
sys-libs/zlib
kerberos? ( virtual/krb5 )
sasl? ( >=dev-libs/cyrus-sasl-2 )
- ssl? ( dev-libs/openssl )
+ ssl? ( dev-libs/openssl:0= )
python? ( ${PYTHON_DEPS} )
- berkdb? ( sys-libs/db )
+ berkdb? ( sys-libs/db:* )
"
RDEPEND="${DEPEND}"
diff --git a/net-nntp/inn/inn-2.5.4-r1.ebuild b/net-nntp/inn/inn-2.5.4-r1.ebuild
index 72f69f229541..19a769d0a7cd 100644
--- a/net-nntp/inn/inn-2.5.4-r1.ebuild
+++ b/net-nntp/inn/inn-2.5.4-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
inherit autotools eutils multilib python-single-r1 ssl-cert toolchain-funcs
@@ -15,7 +16,6 @@ LICENSE="ISC GPL-2+ public-domain BSD-4 BSD-2 RSA BSD MIT GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="berkdb innkeywords inntaggedhash ipv6 kerberos perl python sasl ssl"
-
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="
@@ -25,9 +25,9 @@ DEPEND="
sys-libs/zlib
kerberos? ( virtual/krb5 )
sasl? ( >=dev-libs/cyrus-sasl-2 )
- ssl? ( dev-libs/openssl )
+ ssl? ( dev-libs/openssl:0= )
python? ( ${PYTHON_DEPS} )
- berkdb? ( sys-libs/db )
+ berkdb? ( sys-libs/db:* )
"
RDEPEND="${DEPEND}"
diff --git a/net-nntp/inn/inn-2.5.5-r1.ebuild b/net-nntp/inn/inn-2.5.5-r1.ebuild
index 72f69f229541..19a769d0a7cd 100644
--- a/net-nntp/inn/inn-2.5.5-r1.ebuild
+++ b/net-nntp/inn/inn-2.5.5-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
inherit autotools eutils multilib python-single-r1 ssl-cert toolchain-funcs
@@ -15,7 +16,6 @@ LICENSE="ISC GPL-2+ public-domain BSD-4 BSD-2 RSA BSD MIT GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="berkdb innkeywords inntaggedhash ipv6 kerberos perl python sasl ssl"
-
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="
@@ -25,9 +25,9 @@ DEPEND="
sys-libs/zlib
kerberos? ( virtual/krb5 )
sasl? ( >=dev-libs/cyrus-sasl-2 )
- ssl? ( dev-libs/openssl )
+ ssl? ( dev-libs/openssl:0= )
python? ( ${PYTHON_DEPS} )
- berkdb? ( sys-libs/db )
+ berkdb? ( sys-libs/db:* )
"
RDEPEND="${DEPEND}"