summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/biglybt')
-rw-r--r--net-p2p/biglybt/Manifest2
-rw-r--r--net-p2p/biglybt/biglybt-3.3.0.0.ebuild (renamed from net-p2p/biglybt/biglybt-3.2.0.0-r2.ebuild)20
-rw-r--r--net-p2p/biglybt/metadata.xml2
-rw-r--r--net-p2p/biglybt/plugins/azupdater/Updater.jarbin0 -> 23974 bytes
-rw-r--r--net-p2p/biglybt/plugins/azupdater/azupdater_2.1.zipbin0 -> 27241 bytes
-rw-r--r--net-p2p/biglybt/plugins/azupdater/azupdaterpatcher_2.0.jarbin0 -> 2970 bytes
-rw-r--r--net-p2p/biglybt/plugins/azupdater/plugin.properties4
-rw-r--r--net-p2p/biglybt/plugins/azupdater/plugin.properties_2.13
8 files changed, 17 insertions, 14 deletions
diff --git a/net-p2p/biglybt/Manifest b/net-p2p/biglybt/Manifest
index c61bfad3b978..1ca6ef7e01e8 100644
--- a/net-p2p/biglybt/Manifest
+++ b/net-p2p/biglybt/Manifest
@@ -1 +1 @@
-DIST biglybt-3.2.0.0.tar.gz 34985099 BLAKE2B 385a6cf4f89b0922f06a2a5c7e89a4c9b717922f491717ade3cb13251c88e497cd2f807fa67ce3384bc3fcf3f37af368d20c2bb8984eff9d4237519d2be0f89d SHA512 0a39243271153758482ac3eaef50e4a83464cf67779b531fb29d7289fa49f2ec7dbe5c1c9de1d6b3bed555a6c581c4e95563e333aad4a9e32cf158db1325fef0
+DIST biglybt-3.3.0.0.tar.gz 39452405 BLAKE2B 40a11d9b9d085457cfcfe2c62d30b77a971169f879e55ec5f75b049a0d9639d750cbc8d6a64912ab9beb6fc3c0a4065303f3f64ad48247a55e05089d8fb1d6b3 SHA512 29533b1c135018a4d487afa3b88e92674033b55ed2369c58c7721d7b0b74dcb141fc4e45a683eb9d4123879db94d3c9bbaca41e74a438562a383923eb4f889de
diff --git a/net-p2p/biglybt/biglybt-3.2.0.0-r2.ebuild b/net-p2p/biglybt/biglybt-3.3.0.0.ebuild
index 8847795e7c12..0729bc588663 100644
--- a/net-p2p/biglybt/biglybt-3.2.0.0-r2.ebuild
+++ b/net-p2p/biglybt/biglybt-3.3.0.0.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom core/pom.xml --download-uri https://github.com/BiglySoftware/BiglyBT/archive/v3.2.0.0.tar.gz --slot 0 --keywords "~amd64" --ebuild biglybt-3.2.0.0.ebuild
-
EAPI=8
JAVA_PKG_IUSE="doc source"
-MAVEN_ID="com.biglybt:biglybt-core:3.1.0.1"
+MAVEN_ID="com.biglybt:biglybt-core:3.3.0.0"
inherit java-pkg-2 java-pkg-simple
@@ -25,7 +22,7 @@ KEYWORDS="~amd64 ~ppc64"
CP_DEPEND="
dev-java/commons-cli:1
- dev-java/swt:4.10
+ dev-java/swt:4.27
"
# Compile dependencies
@@ -38,8 +35,9 @@ CP_DEPEND="
# Due to removal of AENameServiceDescriptor it would fail to start under jdk:1.8
# StartServer ERROR: unable to bind to 127.0.0.1:6880 listening for passed torrent info: \
# sun.net.spi.nameservice.NameServiceDescriptor: Provider com.biglybt.core.util.spi.AENameServiceDescriptor not found
+# Restricting to jdk:11 for https://bugs.gentoo.org/888859
DEPEND="
- >=virtual/jdk-11:*
+ virtual/jdk:11
${CP_DEPEND}
"
@@ -54,6 +52,7 @@ DOCS=(
ChangeLog.txt
README.md
TRANSLATE.md
+ issue_template.md
)
PATCHES=(
@@ -66,6 +65,7 @@ S="${WORKDIR}/BiglyBT-${PV}"
src_prepare() {
default
+ java-pkg-2_src_prepare
# AENameServiceDescriptor fails to compile with jdk >= 11
# https://github.com/BiglySoftware/BiglyBT/pull/2611
# "error: package sun.net.spi.nameservice does not exist"
@@ -111,13 +111,7 @@ src_compile() {
}
src_install() {
- java-pkg_dojar "biglybt-core.jar"
- java-pkg_dojar "BiglyBT.jar"
- java-pkg_dolauncher "biglybt" --main com.biglybt.ui.Main
-
- if use doc; then
- java-pkg_dojavadoc target/api
- fi
+ java-pkg-simple_src_install
if use source; then
java-pkg_dosrc "core/src/*"
diff --git a/net-p2p/biglybt/metadata.xml b/net-p2p/biglybt/metadata.xml
index 05d9678fe88c..a660313d0473 100644
--- a/net-p2p/biglybt/metadata.xml
+++ b/net-p2p/biglybt/metadata.xml
@@ -5,6 +5,8 @@
<email>java@gentoo.org</email>
</maintainer>
<upstream>
+ <bugs-to>https://github.com/BiglySoftware/BiglyBT/issues</bugs-to>
+ <doc>https://github.com/BiglySoftware/BiglyBT/wiki</doc>
<remote-id type="github">BiglySoftware/BiglyBT</remote-id>
</upstream>
</pkgmetadata>
diff --git a/net-p2p/biglybt/plugins/azupdater/Updater.jar b/net-p2p/biglybt/plugins/azupdater/Updater.jar
new file mode 100644
index 000000000000..a9ea8471c077
--- /dev/null
+++ b/net-p2p/biglybt/plugins/azupdater/Updater.jar
Binary files differ
diff --git a/net-p2p/biglybt/plugins/azupdater/azupdater_2.1.zip b/net-p2p/biglybt/plugins/azupdater/azupdater_2.1.zip
new file mode 100644
index 000000000000..4fb02bc0dedb
--- /dev/null
+++ b/net-p2p/biglybt/plugins/azupdater/azupdater_2.1.zip
Binary files differ
diff --git a/net-p2p/biglybt/plugins/azupdater/azupdaterpatcher_2.0.jar b/net-p2p/biglybt/plugins/azupdater/azupdaterpatcher_2.0.jar
new file mode 100644
index 000000000000..601624350f93
--- /dev/null
+++ b/net-p2p/biglybt/plugins/azupdater/azupdaterpatcher_2.0.jar
Binary files differ
diff --git a/net-p2p/biglybt/plugins/azupdater/plugin.properties b/net-p2p/biglybt/plugins/azupdater/plugin.properties
new file mode 100644
index 000000000000..5243168ce751
--- /dev/null
+++ b/net-p2p/biglybt/plugins/azupdater/plugin.properties
@@ -0,0 +1,4 @@
+plugin.version=2.1
+plugin.class=com.biglybt.update.UpdaterUpdateChecker;com.biglybt.update.UpdaterPatcher
+plugin.name=BiglyBT Update Support;BiglyBT Updater Support Patcher
+plugin.install_if_missing=yes
diff --git a/net-p2p/biglybt/plugins/azupdater/plugin.properties_2.1 b/net-p2p/biglybt/plugins/azupdater/plugin.properties_2.1
new file mode 100644
index 000000000000..9eb95f0168de
--- /dev/null
+++ b/net-p2p/biglybt/plugins/azupdater/plugin.properties_2.1
@@ -0,0 +1,3 @@
+plugin.class=com.biglybt.update.UpdaterUpdateChecker;com.biglybt.update.UpdaterPatcher
+plugin.name=BiglyBT Update Support;BiglyBT Updater Support Patcher
+plugin.version=2.1