summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild')
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
index a1f4a660f6b9..38cf197f4977 100644
--- a/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,7 +14,7 @@ REQUIRED_USE="cpu_flags_x86_sse2"
DEPEND="
dev-libs/gmp:0
dev-libs/jansson
- curl? ( >=net-misc/curl-7.15[ssl] )
+ >=net-misc/curl-7.15[ssl]
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
"
@@ -35,7 +35,7 @@ src_prepare() {
src_configure() {
append-ldflags -Wl,-z,noexecstack
- econf --with-crypto $(use_with curl)
+ econf --with-crypto --with-curl
}
src_install() {
@@ -44,3 +44,7 @@ src_install() {
insinto "/etc/${PN}"
doins cpuminer-conf.json
}
+
+src_test() {
+ ./cpuminer --cputest || die
+}